Closed Bug 394571 Opened 16 years ago Closed 15 years ago

Can't view download info/properties while downloading

Categories

(Toolkit :: Downloads API, defect)

defect
Not set
normal

Tracking

()

VERIFIED WONTFIX

People

(Reporter: asqueella, Assigned: madhava)

References

Details

(Keywords: regression)

Since the DM redesign, you can't see the info pane (former properties) while downloading. Sometimes I need to see/copy the URL I'm downloading the file from.
Flags: blocking-firefox3?
Flags: in-litmus?
OS: Windows XP → All
Hardware: PC → All
Whiteboard: ui-wanted
Bug 391896?  There's not a nice way to make the info button available now.
(I just saw your comment in that bug, but I still think that bug will be fixed, but this one might be wontfixed)
When I filed the bug, I needed to see the URL I'm downloading from (to check what nightly I was downloading). Having to copy the URL just to look at it is weird.

There's no need for a button (it's less convenient to use for me, btw), you can bring back the context menu item.
(In reply to comment #3)
> When I filed the bug, I needed to see the URL I'm downloading from (to check
> what nightly I was downloading). Having to copy the URL just to look at it is
> weird.
> 
> There's no need for a button (it's less convenient to use for me, btw), you can
> bring back the context menu item.

We've brought back the context menu item "Copy Source Location" with bug 227749
; does that do what you wanted/needed?
No, but it's up to the UI people to decide whether letting people *see* the download info while downloading is important.
Blocking on a UI decision, assigning to madhava for that.
Assignee: nobody → madhava
Flags: blocking-firefox3? → blocking-firefox3+
I know that there are people who will want this information, but given that it seems like an edge-case and that there is a work-around (copying or going to the "source location") I'd be inclined to leave it out.  We want the display to be as uncomplicated as possible.
No longer blocking on UI decision, and as per comment 7, WONTFIX.
Status: NEW → RESOLVED
Closed: 15 years ago
Flags: blocking-firefox3+
Resolution: --- → WONTFIX
Whiteboard: ui-wanted
As far as I can tell, comment 7 is only half a work-around... it doesn't get you the destination folder. Is there any other reasonable way of getting that? While it might seem silly to some, I don't know how many times I've hit Save without remembering what folder it was pointing to, or been using an unfamiliar computer with a default save folder.

There doesn't need to be an info/properties button on the UI, but I don't think it's unreasonable to have it in the context menu for the download again. Previous comments already spoke to this, but comment 7 seems to be operating on the assumption that everyone wanted a button.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
(In reply to comment #7)
> I know that there are people who will want this information, but given that it
> seems like an edge-case and that there is a work-around (copying or going to
> the "source location") I'd be inclined to leave it out.  We want the display to
> be as uncomplicated as possible.

I have never seen another download manager that conceals the download source and the destination the way FF3 does.  Not even a tool-tip. There is nothing complicated about invoking a properties dialog from the context menu as in FF2.  Nothing is gained by removing that menu item.
You need to log in before you can comment on or make changes to this bug.