Up/down keys in input field with autocomplete disabled move text caret

RESOLVED DUPLICATE of bug 294642

Status

()

Toolkit
Form Manager
--
minor
RESOLVED DUPLICATE of bug 294642
10 years ago
2 years ago

People

(Reporter: Steven Barnett, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007090105 Minefield/3.0a8pre

In a text field with autocomplete disabled, when the up/down keys are pressed on the keyboard the text caret moves left/right within the field. Normally only the left/right keys do this, not up/down.

Reproducible: Always

Steps to Reproduce:
1. Open testcase.
2. Click in the first input field, and press the up/down keys. The cursor does not move, as expected.
3. Click in the second input field, and press the up/down keys. The cursor moves, but it should not.
(Reporter)

Comment 1

10 years ago
Created attachment 279308 [details]
testcase

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 294642
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit

Updated

2 years ago
See Also: → bug 1260840
You need to log in before you can comment on or make changes to this bug.