Searching in history sidebar doesn't work / returns nothing.

VERIFIED FIXED in Firefox 3 alpha8

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: stevee, Assigned: dietrich)

Tracking

({regression})

Trunk
Firefox 3 alpha8
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.57 KB, patch
(not reading, please use seth@sspitzer.org instead)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a8pre) Gecko/2007090205 Minefield/3.0a8pre ID:2007090205

1. New profile, start firefox
2. Visit a load of sites
3. Open history sidebar (CTRL+H)
4. Search for something that's in your history

Expected:
- Results returned

Actual:
- Nothing ever returned

Nothing is thrown to the error console (that I can see, anyway)
Flags: blocking-firefox3?
(Reporter)

Comment 1

11 years ago
Works: 20070901_1244_firefox-3.0a8pre.en-US.win32
Broken: 20070901_1429_firefox-3.0a8pre.en-US.win32

Checkins to module PhoenixTinderbox between 2007-09-01 12:44 and 2007-09-01 14:28 : 
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1188675840&maxdate=1188682139

Due to bug 317847
Blocks: 317847
(Assignee)

Updated

11 years ago
Assignee: nobody → dietrich
Component: History → Places
OS: Windows 2000 → Windows 95
Hardware: PC → All
Target Milestone: --- → Firefox 3 M8
(Reporter)

Updated

11 years ago
OS: Windows 95 → All
(Assignee)

Comment 2

11 years ago
Created attachment 279484 [details] [diff] [review]
fix v1

the included test fails without this fix.
Attachment #279484 - Flags: review?(sspitzer)
Comment on attachment 279484 [details] [diff] [review]
fix v1

r=sspitzer, thanks for the adding a test as well.
Attachment #279484 - Flags: review?(sspitzer) → review+
QA Contact: history → places
(Assignee)

Comment 4

11 years ago
Checking in toolkit/components/places/src/nsNavHistory.cpp;
/cvsroot/mozilla/toolkit/components/places/src/nsNavHistory.cpp,v  <--  nsNavHistory.cpp
new revision: 1.165; previous revision: 1.164
done
Checking in toolkit/components/places/tests/unit/test_history.js;
/cvsroot/mozilla/toolkit/components/places/tests/unit/test_history.js,v  <--  test_history.js
new revision: 1.7; previous revision: 1.6
done
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a8pre) Gecko/2007090614 Minefield/3.0a8pre ID:2007090614
VERIFIED
Status: RESOLVED → VERIFIED
(Reporter)

Updated

11 years ago
Flags: blocking-firefox3?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.