The default bug view has changed. See this FAQ.

trust junk mail does not work and the scrollbar window appears to be smaller

RESOLVED FIXED

Status

SeaMonkey
Installer
--
major
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: zetka, Assigned: mcsmurf)

Tracking

({fixed-seamonkey1.1.5, fixed1.8.1.8, regression})

SeaMonkey 1.1 Branch
x86
Windows XP
fixed-seamonkey1.1.5, fixed1.8.1.8, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070802 SeaMonkey/1.1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070802 SeaMonkey/1.1.4

Having SeaMonkey 1.1.1.5, tried to activate function "Trust junk mail headers", but:
1. the scrolled window is smaller in height than the window for "Collected Adresses"
2. When clicking on that scrol window, nothing offers (I awaited SpamAssasin or similar choose for headers)
3. I have tested both GUI windows settings of font size, it happens for boths. 


Reproducible: Always

Steps to Reproduce:
1. olen mail and newsgroup settings, junk settings
2. looking right from Trust mail headers, the scroll window is about 50% in height
3.clicking on its arrow- nothing is offered.
Actual Results:  
the function does not work or I am not able to activate it, the srollbar window is smaller in height in comparsion to the window "do not mark mail.." above.

Expected Results:  
In the window set by I await to have some possibility to choose an external antispam program, such as spamassasin.
(Reporter)

Comment 1

10 years ago
Created attachment 279567 [details]
a view to the setting window with wrong dimension

the height of the trust window is smaller, nothing offered, only white.
I haven't confirmed this yet, but looks like a regression from bug 368074, so requesting blocking SM 1.1.5.

We're not packaging the SpamAssasin files from the bin/isp folder (we're currently trying to get package them in the bin/defaults/messenger directory) which is what I would expect to give the problem shown in the attached image.
Flags: blocking-seamonkey1.1.5?
Keywords: regression
Version: unspecified → SeaMonkey 1.1 Branch
(Reporter)

Comment 3

10 years ago
Maybe I am wrong or not fully understanding, but in my SeaMonkey even in its directory tree or in the Documents folder, there is no bin/messenger directory, the SpamAssain.sfd could be found in the Documents folder /Default User/xxxxxxx directory, where is the whole profile.
(Assignee)

Comment 4

10 years ago
Created attachment 279609 [details] [diff] [review]
Patch for 1.8 branch
(Assignee)

Updated

10 years ago
Attachment #279609 - Flags: review?(bugzilla)
(Assignee)

Updated

10 years ago
Assignee: mail → nobody
Status: UNCONFIRMED → NEW
Component: MailNews: Account Manager → Installer
Ever confirmed: true
QA Contact: general
(Reporter)

Comment 5

10 years ago
IFrank,
I am a newbie, without help or point how to instal the given file I am not able to test it. I do not know 1.8 branch, is it for sea monkey and Win XPs? 
I have Sea monkey 1.1.4 (sorry for 1.1.5, it was futuristc..) as stated above.
Regards,
pronajem
(Assignee)

Comment 6

10 years ago
Created attachment 279624 [details] [diff] [review]
Better patch
Assignee: nobody → bugzilla
Attachment #279609 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #279624 - Flags: review?(bugzilla)
Attachment #279609 - Flags: review?(bugzilla)
Comment on attachment 279624 [details] [diff] [review]
Better patch

r=me, though we should make sure we verify this in tomorrow's nightlies as well.
Attachment #279624 - Flags: review?(bugzilla) → review+
(Assignee)

Updated

10 years ago
Attachment #279624 - Flags: approval-seamonkey1.1.5?

Comment 8

10 years ago
Comment on attachment 279624 [details] [diff] [review]
Better patch

looks good enough for the stable branch - given it works :)
a=me for 1.1.5
Attachment #279624 - Flags: approval-seamonkey1.1.5? → approval-seamonkey1.1.5+
(Assignee)

Comment 9

10 years ago
pronajem.garsonka: You can download from http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-mozilla1.8/ tomorrow a new build to test if this bug is then fixed for you (these builds are the SeaMonkey 1.1.x development line). It should be.

Checked in:
Checking in xpinstall/packager/packages-win;
/cvsroot/mozilla/xpinstall/packager/Attic/packages-win,v  <--  packages-win
new revision: 1.291.4.9; previous revision: 1.291.4.8
done
Checking in xpinstall/packager/packages-unix;
/cvsroot/mozilla/xpinstall/packager/Attic/packages-unix,v  <--  packages-unix
new revision: 1.311.4.12; previous revision: 1.311.4.11
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: fixed-seamonkey1.1.5, fixed1.8.1.7
Resolution: --- → FIXED
(Reporter)

Comment 10

10 years ago
I have downloaded and installed the 1.1.5pre version from the FTP, verified, that it is correctly installed, but the Trust window seems the same as before, no changes, smaller size. Tried to choose something from the scroll menu, nothing happens, nothing is offered.
I have looked at the 1.1.4 at home, the above bug is there too.
Any idea what to do, or maybe some corrupted files on my side?
Regards,
pronajem.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

10 years ago
Should I have said "and look at the date, too" ;-)? The date behind the files there is still "04-Sep-2007". Download when it is 05-Sep-2007, should happen in a few hours ;-).
(Reporter)

Comment 12

10 years ago
Fine, I will look at the date. Maybe one comment (or point to wishlist)- from the philosophical point of view I would reccomend following. As far as most of us are bombed every day with lots of spam, the internal Junk mail filter even trained is not enough, and in my case quite often making errors. The possibility to move manually email to junk works only if the internal Junk mail adaptive control is working.
I would reccomend to let the marking/moving manually function to work independently if the adaptive control is switched on or off. The antispam programs like assasin work much more efficiently than the small Bayesian.But that is a longer story.
Regards,

Comment 13

10 years ago
Functionality changes can not be done in SeaMonkey 1.1.x and should be filed as separate bugs which developers may be able to look into for newer versions, like SeaMonkey 2. 
(Assignee)

Comment 14

10 years ago
I tested this with a build from the ftp server and this seems to work, resolving as FIXED again.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

10 years ago
I confirm the change and the appearance of the SpamAssasin in the window and changing its size too. 
But concerning the function point of view, I am not very sure if it works (and how), because although we use the spamaassasin  and there is an visible entry in the message header, but the mail was not recognized and not marked. As I have said before, I am using the soft only and if its not necessary, I do not go deep in the documentation (if exists) but in Mozilla- Sea Monkey some information (how-to's) are missing, in help sure. If somebody can point me to the source, how and where must be in the header the entry and its form for SpamAssasin to activate the trust mail header, it can be very helpful, because without that it is only a half work done I think.
So that is from my side, thanks for the updating.

Updated

10 years ago
Summary: trust junk mail does not work and the srolbar window appears to be smaller → trust junk mail does not work and the scrollbar window appears to be smaller

Updated

10 years ago
Flags: blocking-seamonkey1.1.5?
(Assignee)

Comment 16

10 years ago
zetka: Are you using POP3 or IMAP? I tried with IMAP here and moving to Junk folder (mark as junk) also does not seem to work here (I added a X-Spam-Status: Yes header to test this) with 1.1.5pre. On trunk it does work though. Someone else reported that mark as junk does work though for him with 1.1.4 and POP3.
(Reporter)

Comment 17

10 years ago
In my case I am using POP3, but because the headers of the SpamAssasin on our server are looking different, I had to change the content of the filter to match the our entries, but I am really not sure due to the filtering, what triggered.

Concerning how it works I have the feeling, that if I have not active the "Enable adaptive....", than the Trust mail headers does not work. If I activate it, the internal Junk filter is making errors (rate about 1/50), so I have made custom filter to read our SpamAssasin headers and leave it. In case that there will be no way to stop the internal Bayesian filter, but to have "Trust junk... " and "Automaticaly delete" active. 
In other case I think it is not usefull.

A one thing could be very usefull. Into the message filter tools, into the actions, there could be a very good helping thing to have a possibility to add into the email header or similar some entry, where will be marked which filter the message triggered and moved it, similarly líke the external antispams do. 
So I am not sure if it helps, I can test it tomorrow, every day I have about 50-100 spams, so I disable the filters and try it.
Regards, zetka.
You need to log in before you can comment on or make changes to this bug.