Closed Bug 394875 Opened 12 years ago Closed 9 years ago

xpcshell-tests should be installed to _tests/xpcshell/$relativesrcdir

Categories

(Testing :: XPCShell Harness, enhancement)

enhancement
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 586754

People

(Reporter: ted, Unassigned)

Details

Attachments

(1 obsolete file)

xpcshell-based unit tests currently get installed to _tests/xpcshell-simple/$MODULE.  This is fine, but for some of the work I'm doing in bug 379327 and bug 394250, it would be nice if they were installed using the relative src path like mochitests, since we could then give a bonsai link in the tinderbox log output for failures.  Mochitest accomplishes this by having the Makefile.in set "relativesrcdir", for example: http://mxr.mozilla.org/mozilla/source/content/base/test/Makefile.in#42 .  We could use this same var for xpcshell tests, then the unit test output would be easily bonsai-linkable.
Depends on: 395019
Trivial patch assuming we fix bug 395019.
Assignee: nobody → ted.mielczarek
Status: NEW → ASSIGNED
Attachment #280414 - Flags: review?(benjamin)
this looks fine to me, but I'm no bsmedberg. :)
Attachment #280414 - Flags: review?(benjamin) → review+
Attachment #280414 - Flags: approval1.9?
Comment on attachment 280414 [details] [diff] [review]
use relativesrcdir instead of MODULE
[Superseded by bug 586754]

Removing approval request since I backed out bug 395019.
Attachment #280414 - Flags: approval1.9?
Blocks: 378090
Morphing. I have decided that instead we should just run tests from the srcdir.
Assignee: ted.mielczarek → nobody
Component: Testing → TUnit
No longer depends on: 395019
Product: Core → Testing
QA Contact: testing → tunit
Summary: xpcshell-based unit test framework should install tests to _tests/xpcshell-simple/$relativesrcdir → xpcshell-based unit test framework should run tests from srcdir
Version: Trunk → unspecified
Attachment #280414 - Attachment is obsolete: true
(In reply to comment #4)
> I have decided that instead we should just run tests from the srcdir.

Wouldn't this be the opposite of what was done in bug 421611?
Blocks: 421611
No longer blocks: 378090
Severity: normal → enhancement
Version: unspecified → Trunk
You're right.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
Should we unmorph the bug, to s/MODULE/relativesrcdir/g?
That'd be fine, if you want to fix it.
Unmorphing.
No longer blocks: 421611
Status: RESOLVED → REOPENED
Depends on: 395019
Resolution: WONTFIX → ---
Summary: xpcshell-based unit test framework should run tests from srcdir → xpcshell-tests should be installed to _tests/xpcshell/$relativesrcdir
Status: REOPENED → NEW
Duplicated to bug 586754, isn't it?
Attachment #280414 - Attachment description: use relativesrcdir instead of MODULE → use relativesrcdir instead of MODULE [Superseded by bug 586754]
yes, this is the same thing except not using some automatic relativesrcdir trick.
No longer blocks: 379327
No longer depends on: 395019
Status: NEW → RESOLVED
Closed: 11 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 586754
V.Duplicate, per comment 11.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.