Closed Bug 394935 Opened 12 years ago Closed 12 years ago

Drop-down boxes show no option

Categories

(Webtools Graveyard :: Litmus, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: pascalc, Assigned: coop)

References

()

Details

1: go to http://litmus.mozilla.org/show_test.cgi?id=2773
2: Login with your litmus account
3: Click on "Submit single test result for this testcase"
4: click on any Pass/fail
5: click on "platform" "operating system" or "locale" select boxes to provide details

expected result:
select the OS and Locale used for this test 

actual result:
empty dropdown boxes, html source shows that there are no <option> items in the select boxes

Tested with Firefox 2.0.0.6 and Firefox 3a7 on Linux Ubuntu, same bug confirmed by another linux user using OpenSuse, Tomcat cannot reproduce the bug with his windows box, could be OS specific. Changing the UA to pretend to be IE7/Vista does not change the result.
WFM under FC7. 

Does this happen if you are already logged in before you navigate to the page? Does Firebug (or equiv) show any JS errors? 
Also, the OS box won't populate until the platform box is selected, but it sounds like none of the boxes are populating for you.
When I visit a single testcase's page, I experience the same thing as ___ does. I tested different builds with my profile and without it. My error console is quiet, sadly.

My computer runs a "Fedora release 7 (Moonshine)" (string found in /etc/fedora-release) with the default repositories plus freshrpm and google's rep. I have KDE and Gnome installed. My regular FF profile's active extensions are: About this Site, Beagle Indexer, British English Dictionary, del.icio.us (official), MySpell French Dictionnary (1900's reform), DOM Inspector, DOWNThemAll, Firebug, FullerScreen, Google Gears, Operator, Scrapbook, Slogger, Web Developer, and XPather.

Minefield/3.0a8pre (Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007090704 Minefield/3.0a8pre) with a clean profile and with my regular profile gives me the same results.

Fedora's rpm build (BI: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.5) Gecko/0000000000 Fedora/2.0.0.5-1.fc7 Firefox/2.0.0.5) with a clear profile and my regular profile gives me same results.

With Mozilla's build Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.6) Gecko/2007072517 Firefox/2.0.0.6 with my regular profile and a new one, same thing.

In case it's useful, I have the same issue with Konqueror.
I'm seeing the same problem over here. The thing is when going to http://litmus.mozilla.org/show_test.cgi?id=4625 I am actually able to get something in the error console. The URL listed for this bug does not give a message in the error console. When viewing testcase 4625 this is shown in the error console:

Error: theField has no properties
Source File: http://litmus.mozilla.org/js/FormValidation.js
Line: 385

Of course, what happens is the same as the others. The locales is unfilled and there are no real choices for platform or os, only the first place holder ones items.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007092809 Minefield/3.0a9pre ID:2007092809
I am getting the same thing.  Running individual test cases from the  FX3.0-Security-Privacy(834) subgroup results in empty pull-down menues for Platform and OS. See http://litmus.mozilla.org/show_test.cgi?searchType=by_category&product_id=1&branch_id=15&testgroup_id=56&subgroup_id=834 and then try running test case 4625 or 4626.  Then select "submit single test result..."  This happens on both XP and Mac OS

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007092804 Minefield/3.0a9pre

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007092604 Minefield/3.0a9pre

Running tests from the offered sets of test at login work fine.  See: http://litmus.mozilla.org/run_tests.cgi?test_run_id=2  Of course this a configuratin setup window rather than the submission window I am talking baout in the first paragraph.
(In reply to comment #4)
> Error: theField has no properties
> Source File: http://litmus.mozilla.org/js/FormValidation.js
> Line: 385

FWIW, this was actually bug 394238 for which the fix landed yesterday. I don't expect that to fix this problem though.
This might be related to the order in which we execute the JS on the page. Since we're looking up the build ID, if the user has not enabled the user_pref for codebase_principal_support, we might be bailing out early on the rest of the JS if we hit that exception. Something to investigate next week.
Leftover admin check removed.

Checking in show_test.cgi;
/cvsroot/mozilla/webtools/litmus/show_test.cgi,v  <--  show_test.cgi
new revision: 1.25; previous revision: 1.24
done
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.