Closed Bug 395326 Opened 15 years ago Closed 15 years ago

Printing page with frames only prints first page

Categories

(Camino Graveyard :: Printing, defect)

PowerPC
macOS
defect
Not set
major

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 178554

People

(Reporter: aboyer, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.6) Gecko/20070809 Camino/1.5.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.6) Gecko/20070809 Camino/1.5.1

If a page with multiple frames spreads across pages, only the first one comes out.  The dialog says "Processing Page: 1" and then goes away; the progress bar gets halfway (in case of 2 page doc).  Preview opens and shows only one page, but hte footer says "1 of 2".
Noticed in Camino 1.5 and 1.5.1, on my Powerbook G4 and my wife's MacBook.  Happens every time whether you preview, print to pdf, or actually print.

Reproducible: Always

Steps to Reproduce:
1. Go to a page with frames, such as my personal site (www.tobark.org). [No ads]
2. If it's a big page, go to step 3.  If it's a small page crank up the scale in Page Setup so it spreads over more than one page.
3. Print and select Print Preview.
Actual Results:  
Doc with 1 page containing part of website; footer says "1 of 2" or "1 of 3" etc.

Expected Results:  
Printed the entire website spread over multiple pages.

Happens on multiple internal university sites like Blackboard / CourseWeb, not just my personal site.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 178554
You need to log in before you can comment on or make changes to this bug.