Crash on sites with Java applets with AdBlock Plus 0.7.5.1 installed

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: gerd_roethig, Assigned: Biesinger)

Tracking

(Blocks: 1 bug, {crash, regression})

Trunk
x86
Windows XP
crash, regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.9a8pre) Gecko/2007090704 Minefield/3.0a8pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/20070905 Minefield/3.0a8pre

There are several Java-related crashes when AdBlock Plus is installed.

Here's another one.

Steps to reproduce:

With AdBlock Plus installed, go to http://www.java.com/en/download/installed.jsp and click on the green "Verify Installation" button.

Reproducible: Always

Steps to Reproduce:
1. Have AdBlock Plus 0.7.5.1 installed (filter settings do not matter)
2. Go to http://www.java.com/en/download/installed.jsp .
3. Click the green "Verify Installation" button.
Actual Results:  
Crash with Breakpad trigger:
http://crash-stats.mozilla.com/report/index/da4932d7-5d5e-11dc-96ec-001a4bd46e84
http://crash-stats.mozilla.com/report/index/3d3753e3-5d5e-11dc-a943-001a4bd43ef6
(just two examples)

Expected Results:  
The result of the Java installation verification process should be shown.
Expected is information if you have the most recent version of Java installed.

Regressionwindow:

Works in 20070905_1328
Broken in 20070905_1344 

Can be circumvented by de-installing AdBlock Plus (de-activating only does not help!)
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk

Updated

11 years ago
Flags: blocking-firefox3?
Keywords: crash, regression
(Reporter)

Updated

11 years ago
Blocks: 393845
(Reporter)

Comment 2

11 years ago
Another testcase:

1. Go to http://www.screencast-o-matic.com/watch/ciiXQIZy
2. Wait for the Java applet to load (the Java logo is shown and then it disappears).
3. Firefox crashes.(unfortunately no Breakpad because it came up but it did not work this time, using 20070905_1344 - perhaps Breakpad is broken in that build)
Regressionwindow checked, it's the same as above:
Works in 20070905_1328
Broken in 20070905_1344
(Reporter)

Comment 3

11 years ago
Seems that Breakpad only works from time to time, got a "fresh" report now:

http://crash-stats.mozilla.com/report/index/56593acc-5e17-11dc-abcf-001a4bd43ed6
Component: General → Plug-ins
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: general → plugins
Flags: blocking1.9?
Fwiw, the Java plugin itself probably has some major issues itself.
I get this same crash when loading the testcase I attached in bug 275783, https://bugzilla.mozilla.org/attachment.cgi?id=279607
then loading a different site and then going back.
Created attachment 280283 [details]
testcase

Not sure, but this is probably the same issue as what happens in combination with Adblock Plus.
This is crashing for me (can someone confirm, I don't have the right Java version currently)
Created attachment 280284 [details]
testcase2

This time using embed to invoke the Media Player, which is also crashing for me, after the patch for bug 393845 landed.
(Reporter)

Updated

11 years ago
Summary: Crash on Java install verification with AdBlock Plus 0.7.5.1 installed → Crash on sites with Java applets with AdBlock Plus 0.7.5.1 installed
(Reporter)

Comment 7

11 years ago
I think that the crash is independent from the Java version installed (just did not have the time to verify this).
Biesi: could this be a regression from your fix to bug 393845
Assignee: nobody → cbiesinger
Flags: blocking1.9? → blocking1.9+
Another site that crashes directly after a reload for me:
http://www.knbc.com/videostream/10954229/detail.html?treets=la&tml=la_break&ts=T&tmi=la_break_1_08350209242007
This also regressed when the patch for bug 393845 was checked in.
This should be fixed by the backout of bug 393845
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Flags: in-testsuite?

Updated

10 years ago
Blocks: 467520
You need to log in before you can comment on or make changes to this bug.