Closed Bug 395437 Opened 13 years ago Closed 13 years ago

'Dismiss All' doesn't dismiss all alarms (skips every second)

Categories

(Calendar :: Alarms, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: ssitter)

References

Details

(Keywords: regression)

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.7pre) Gecko/20070907 Calendar/0.7pre

'Dismiss All' doesn't dismiss all alarms (skips every second)

Steps to Reproduce:
1. Create four events with alarms set (e.g. event '1', '2', '3' and '4')
2. Wait until all four alarms are fired and press 'Dismiss All'
3. Restart Sunbird

Actual Results:
Alarm popup for event '2' and '4' are displayed.

Expected Results:
No alarm popup because all alarms were dismissed.

Same error was fixed with Bug 353051 for Sunbird 0.3 but was regressed by the checkin for Bug 389245.
Flags: blocking-calendar0.7?
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #280113 - Flags: review?(daniel.boelzle)
OS: Windows 2000 → All
Hardware: PC → All
Version: Trunk → unspecified
Comment on attachment 280113 [details] [diff] [review]
rev0 - loop in reverse order

good catch, thanks for the patch; r=dbo
Attachment #280113 - Flags: review?(daniel.boelzle) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.7
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7pre) Gecko/20070908 Calendar/0.7pre
Status: RESOLVED → VERIFIED
Flags: blocking-calendar0.7? → in-litmus?
Litmus Testcase 2695 was created for this, see Bug 353051 Comment #11.
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.