flash not rendered according to div z-index, flash stays always on top

RESOLVED DUPLICATE of bug 137189

Status

()

defect
RESOLVED DUPLICATE of bug 137189
12 years ago
12 years ago

People

(Reporter: martinbraun, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.16) Gecko/20070725 Firefox/2.0.0.6

This seems to be a rather persistent problem for some time now. I would like to repost this to get insight on the status of this issue and if it will be resolved anytime soon. 
The problem can be described quickly: 
HTML content cannot be placed on top of flash content using the css "z-index" property with position:absolute or position:relative on firefox on the Linux oprating system. Layering flash content works well on Internet Explorer and Firefox on windows (see example). 

I have seen some linux examples working with position:fixed, placing a single html element on top above everything else (including flash). 
Further, a (quite ugly) workaround exist using an iframe layered in between the flash movie and the div. However this does not work with (semi)transparent html content on top of the flash movie. 
(see http://blog.marcoos.com/2006/07/21/html-div-above-a-flash-animation-on-linux-its-possible/)

I've read about similar issues affecting java applets, so I suppose this is not a flash specific problem but rather a problem in the plugin handling in general. 

Regarding the persistence of this problem I suppose it is not so easy to fix. Could you give some statement if this issue will be fixed in near future? Also, what role does the penguin.swf project play in relation to this issue? Should this problem rather be adressed to Adobe/penguin.swf?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
see bug 137189#c87 and comment #93
The plugin must support it

"I would like to repost this to get insight on the status of this issue"
Please don't do this ! 
You have to search yourself in the database if you want answers and if you need further help to find informations ask on IRC,thew newsgroups or in the mozilalzine.org Forums or elsewhere.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 137189
You need to log in before you can comment on or make changes to this bug.