sort out focus in popup panels

RESOLVED WONTFIX

Status

()

Core
Widget
RESOLVED WONTFIX
11 years ago
10 years ago

People

(Reporter: Neil Deakin, Assigned: Neil Deakin)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 -
wanted1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

11 years ago
The widget code currently expects all popups to behave as menus. However, this isn't actually the case and we have several panel popups, and more have been added recently (identity popup, places popup, customize dialog, etc). Panels should behave as toplevel windows, have no window decorations, may optionally roll up (gRollupWidget will be null if they don't), and receieve key and mouse events.
For instance, one issue is that popups are not made active or focused, yet panels should be focused as regular windows.

There are numerous bugs caused by this or that are harder to fix due to this.
(Assignee)

Comment 1

11 years ago
Created attachment 280785 [details] [diff] [review]
fix some popup issues

This patch doesn't really fix the bug, but improves some problems with panels and focus behaviour in popups. It fixes bugs 395123, 395334 and 390178, and bug 124313. It changes the popup to have a parent so that the child popup is associated with the parent, moves with the parent and appears just over the parent but under other windows. It implements the 'dependent' window open flag on Mac. It also changes noautohide="true" panels so that they can only be used in chrome windows.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
(Assignee)

Updated

11 years ago
Blocks: 124313
Neil: With this patch, the customization sheet (which is a noauthohide-panel) ignores all mouse events.
-'ing for now, but please argue for a + in the 1.9 meeting for this.
Flags: blocking1.9? → blocking1.9-
Whiteboard: [wanted-1.9]
(Assignee)

Comment 4

11 years ago
Created attachment 285407 [details] [diff] [review]
updated patch

This patch fixes the bugs mentioned above, as well as 400019 and 385609 in certain situations.
Attachment #280785 - Attachment is obsolete: true
(Assignee)

Updated

11 years ago
Blocks: 385609, 400019
Summary: widget needs to support non-menu popups → sort out focus in popup panels

Updated

11 years ago
Blocks: 402499
(Assignee)

Updated

11 years ago
No longer blocks: 390197
Flags: wanted1.9+
Whiteboard: [wanted-1.9]
(Assignee)

Comment 5

10 years ago
Much of the stuff in these patches has already been checked in, or is part of other bugs. Going to just close this bug off.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.