Closed Bug 395814 Opened 13 years ago Closed 13 years ago

Crash in [@ nsIFrame::GetProperty] loading/on meebo.com

Categories

(Core :: Plug-ins, defect, critical)

defect
Not set
critical

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: stephend, Unassigned)

References

()

Details

(Keywords: crash, regression)

Crash Data

Build ID: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a8pre) Gecko/2007091104 Minefield/3.0a8pre

Summary: Crash in [@ nsIFrame::GetProperty] loading/on meebo.com

Steps to Reproduce:

1. Load Meebo.com
2. If that doesn't crash, hit Reload/F5

Crash here:

0  	nsIFrame::GetProperty(nsIAtom*, unsigned int*) const  	 mozilla/layout/generic/nsFrame.cpp:701
1 	nsIFrame::GetView() const 	mozilla/layout/generic/nsFrame.cpp:3276
2 	nsPluginInstanceOwner::FixUpPluginWindow(int) 	mozilla/layout/generic/nsLineBox.cpp:4028
3 	nsPluginInstanceOwner::Notify(nsITimer*) 	mozilla/layout/generic/nsLineBox.cpp:3760
4 	nsTimerImpl::Fire() 	mozilla/xpcom/threads/nsTimerImpl.cpp:387
5 	nsTimerEvent::Run() 	mozilla/xpcom/threads/nsTimerImpl.cpp:457
6 	nsThread::ProcessNextEvent(int, int*) 	mozilla/xpcom/threads/nsThread.cpp:490
7 	NS_ProcessNextEvent_P(nsIThread*, int) 	nsThreadUtils.cpp:227
8 	nsBaseAppShell::Run() 	mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:154
9 	-[AppShellDelegate runAppShell] 	mozilla/widget/src/cocoa/nsAppShell.mm:459
10 	__NSFireDelayedPerform 	
11 	CFRunLoopRunSpecific 	
12 	CFRunLoopRunInMode 	
13 	_FirstEventTime 	
14 	ReceiveNextEventCommon 	
15 	ReceiveNextEventCommon 	
16 	_DPSNextEvent 	
17 	-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] 	
18 	-[NSApplication run] 	
19 	nsAppShell::Run() 	mozilla/widget/src/cocoa/nsAppShell.mm:351
20 	nsAppStartup::Run() 	mozilla/toolkit/components/startup/src/nsAppStartup.cpp:170
21 	XRE_main 	mozilla/toolkit/xre/nsAppRunner.cpp:3069
22 	main 	mozilla/browser/app/nsBrowserApp.cpp:153
23 	start 	crt.c:272
24 	start 	
25 	@0x1
Flags: blocking1.9?
Here is my report, adding it because mine shows a different stack then stephen's, but I followed the same steps: Load meebo.com and then reload the page. http://crash-stats.mozilla.com/report/index/747198a8-60a7-11dc-a7d4-001a4bd43ef6?date=2007-09-11-20
I forgot to mention that I'm running version r60 of the Adobe Flash Player Beta; this now crashed on Windows Vista, too, with that installed.
OS: Mac OS X → All
Hardware: PC → All
This is worksforme, with current trunk build.
Is this a recent regression?
When did this regress?
Is this crash specifically happening with version r60 of the Adobe beta Flash Player? Where can I download that one?
Component: Layout: HTML Frames → Plug-ins
QA Contact: layout.html-frames → plugins
martijn: You can download the r60 version at http://labs.adobe.com/. either stephen or I will have to check to see if the current version that is shipping exhibits the same behavior.

(In reply to comment #4)
> This is worksforme, with current trunk build.
> Is this a recent regression?
> When did this regress?
> Is this crash specifically happening with version r60 of the Adobe beta Flash
> Player? Where can I download that one?
> 

Is this WFM now? Also, if this only happens with a specific version of the flash plugin it might be their fault, though the stack does seem to point to us.
(In reply to comment #6)
> Is this WFM now? Also, if this only happens with a specific version of the
> flash plugin it might be their fault, though the stack does seem to point to
> us.

Jonas: seems to be; do you have a specific checkin that we can point at as likely having fixed this?
I guess this might have been fixed by the back-out of the patch from bug 393845.
I don't have any info, i was just going by the comments in the bug to try to figure out if we should mark this as blocking or not.
I tested this on two different machines using Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007092804 Minefield/3.0a9pre. One had the r60 and one had the r47. Resolving as WFM and adding this my tracking list of potential problem sites to follow up on at a later date.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
I haven't been able to reproduce this either, using

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007093004 Minefield/3.0a9pre

Verified WFM; I'll also keep and eye out for it.
Status: RESOLVED → VERIFIED
Flags: blocking1.9?
Crash Signature: [@ nsIFrame::GetProperty]
You need to log in before you can comment on or make changes to this bug.