Closed Bug 395923 Opened 13 years ago Closed 13 years ago

The whole page is repeated in a single node following the ordered list with 8 items on this page.

Categories

(Core :: Disability Access APIs, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: MarcoZ, Assigned: aaronlev)

References

()

Details

(Keywords: access)

Attachments

(2 files)

When visiting http://contributing.openoffice.org/programming.html, JAWS repeats the whole page text, more or less run together in a big chunk of text, after the list of 8 items has concluded, and before the "Say you just want to contribute..." paragraph. AccExplorer32 shows this to be a node of type Hyperlink that is not visible. It may be prompted by the name anchor that starts the paragraph "Say you just want...".
Blocks: fox3access
I also moved the code to see if it's an onclick before the link check, because:
1) if it has an onclick the link is irrelevant
2) it makes the new check for walkUpContent == mDOMNode easier -- we wouldn't want to break if the node has an onclick
Attachment #282168 - Flags: review?(Evan.Yan)
Attachment #282168 - Flags: review?(Evan.Yan) → review+
Attachment #282168 - Flags: approval1.9?
Attachment #282168 - Flags: approval1.9? → approval1.9+
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
(In reply to comment #1)
> Created an attachment (id=282168) [details]
> I also moved the code to see if it's an onclick before the link check, because:
> 1) if it has an onclick the link is irrelevant
> 2) it makes the new check for walkUpContent == mDOMNode easier -- we wouldn't
> want to break if the node has an onclick

Aaron, this now causes all links that also have some sort of onclick handler to be rendered as "clickables" in JAWS instead of links. For example, each "Reply" link on this bug page is no longer rendered as a link, but as a clickable. Is that the effect you were desiring? I'm asking because this causes all sorts of page elements that are links not to appear inside the JAWS Links List anymore, and may cause confusion once users upgrade to FF 3. This might be viewed as a regression, and it makes surfing certain pages less convenient.
I did intend that, because they're not really links. But, you make a good point about it now showing up in the links list.

Reopening to fix that.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #283107 - Flags: review?(surkov.alexander)
Comment on attachment 283107 [details] [diff] [review]
If it's an <a> with an onclick, we should still call it a link

looks ok
Attachment #283107 - Flags: review?(surkov.alexander)
Attachment #283107 - Flags: review+
Attachment #283107 - Flags: approval1.9?
Attachment #283107 - Flags: approval1.9? → approval1.9+
Marco, did I fix this yet? :)
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.