Last Comment Bug 395924 - Deleting a user account may delete other user's whine
: Deleting a user account may delete other user's whine
Status: RESOLVED FIXED
: regression
Product: Bugzilla
Classification: Server Software
Component: User Accounts (show other bugs)
: 3.0.1
: All All
: -- normal (vote)
: Bugzilla 3.0
Assigned To: Frédéric Buclin
: default-qa
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-12 10:21 PDT by Marc Schumann [:Wurblzap]
Modified: 2008-11-27 22:12 PST (History)
3 users (show)
LpSolit: approval+
LpSolit: blocking3.1.3+
LpSolit: approval3.0+
LpSolit: blocking3.0.3+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch, v1 (3.63 KB, patch)
2007-11-19 04:24 PST, Frédéric Buclin
wurblzap: review+
Details | Diff | Splinter Review

Description Marc Schumann [:Wurblzap] 2007-09-12 10:21:03 PDT
This is a regression of bug 119485.

When deleting a user account, all whines (other users', too) where the account being deleted is a direct whinee of will be deleted along with the user account. Instead of deleting the whine as a whole, it should delete the schedule only.

Steps to reproduce:
1. Create a user A (which is the one to be deleted later)
2. Log in as user B
3. Create a whine; create schedules to it so that user A and user B are
   both whinees
4. Delete user A

This deletes the whine created in step 3.
Comment 1 Max Kanat-Alexander 2007-09-13 13:43:28 PDT
This should actually be handled automatically by referential integrity in 3.1. You could try just deleting the profiles entry and a few other things, and see if that actually works. (It should, because of DELETE => 'CASCADE' on most items.)
Comment 2 Frédéric Buclin 2007-11-15 14:07:48 PST
I would hate to see one of my whines being deleted because only one addressee no longer exists. Pushing this regression into our radar for 3.0.3/3.1.3.
Comment 3 Frédéric Buclin 2007-11-19 04:24:49 PST
Created attachment 289298 [details] [diff] [review]
patch, v1
Comment 4 Marc Schumann [:Wurblzap] 2007-11-19 04:30:36 PST
Comment on attachment 289298 [details] [diff] [review]
patch, v1

r=Wurblzap by inspection and believing that I know the code well enough.
Comment 5 Frédéric Buclin 2007-11-19 04:45:55 PST
tip:

Checking in editusers.cgi;
/cvsroot/mozilla/webtools/bugzilla/editusers.cgi,v  <--  editusers.cgi
new revision: 1.145; previous revision: 1.144
done
Checking in template/en/default/admin/users/confirm-delete.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/admin/users/confirm-delete.html.tmpl,v  <--  confirm-delete.html.tmpl
new revision: 1.20; previous revision: 1.19
done


3.0.2:

Checking in editusers.cgi;
/cvsroot/mozilla/webtools/bugzilla/editusers.cgi,v  <--  editusers.cgi
new revision: 1.141.2.1; previous revision: 1.141
done
Checking in template/en/default/admin/users/confirm-delete.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/admin/users/confirm-delete.html.tmpl,v  <--  confirm-delete.html.tmpl
new revision: 1.15.2.2; previous revision: 1.15.2.1
done
Comment 6 Max Kanat-Alexander 2008-06-30 23:36:42 PDT
Probably already relnoted in 3.0.3--in any case, it doesn't need to be relnoted for 3.2, so removing relnote keyword.
Comment 7 Max Kanat-Alexander 2008-07-01 00:07:54 PDT
Added to the release notes for Bugzilla 3.2 in a patch on bug 432331.
Comment 8 Frédéric Buclin 2008-07-01 11:02:52 PDT
(In reply to comment #7)
> Added to the release notes for Bugzilla 3.2 in a patch on bug 432331.

You just said the opposite in comment 6?!
Comment 9 Max Kanat-Alexander 2008-07-01 11:08:32 PDT
(In reply to comment #8)
> You just said the opposite in comment 6?!

  Oh, mistake. I did that with a "Change Several Bugs At Once", so I probably accidentally checked this bug.
Comment 10 Abdul.Sameer 2008-11-27 22:12:49 PST
is there anyway that we can just disable the users account on temporary base.
and i don;t want some of the email id to be seen in some of the projects.

i need one project assigned to one person and other persion email id should not be seen in unassigned project. Is that possible ? if so please do let me know as soon as possible as it is my requirementst with the clients.

Note You need to log in before you can comment on or make changes to this bug.