Closed Bug 396174 Opened 12 years ago Closed 12 years ago

Position in long documents lost after changing font size (ctrl-+/-/0)

Categories

(Firefox :: General, defect, minor)

x86
Linux
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 64926

People

(Reporter: mihai, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20070718 Fedora/2.0.0.5-1.fc7 Firefox/2.0.0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20070718 Fedora/2.0.0.5-1.fc7 Firefox/2.0.0.5

Using the browser to view a long document (like the one in the URL provided), somewhere in the second half. After changing the font size with ctrl-+/-/0, the position in the document is changed quite a lot:
** below, after font increase
** above, after font decrease
The longer the document and the closer to the end the viewport, the worst the displacement.

Reproducible: Always

Steps to Reproduce:
1. Load the page http://lists.w3.org/ (or any long document)
2. Move somewhere in the second half of it and familiarize with some of the page contents
3. Increase the font (ctrl-+).
Actual Results:  
The viewport is shifted to a different part of the document, quite far from the original view.

Expected Results:  
The viewport for the increased font should try to keep the same position in the document for the top of the view (i.e., for text documents, the first line of the view before increase still be the first visible in the view after increase).
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 64926
You need to log in before you can comment on or make changes to this bug.