when changing a recurrent event, need an option to change just the future occurrences

VERIFIED DUPLICATE of bug 320178

Status

Calendar
General
--
enhancement
VERIFIED DUPLICATE of bug 320178
11 years ago
11 years ago

People

(Reporter: Luke J, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Sunbird 0.5

When a user would like to change an iteration of a recurring event (say 3 months from the initiating date), he is given 3 options on how to change that repeating event: Change "All Occurrences", "This Occurrence Only", or "Cancel". I believe it is essential to add one more button - one that is included in Outlook - that says "All Future Occurrences". This will allow the user to keep an accurate record of when the past occurrences took place, because at the moment, one has to change the initial repeating event, which causes all occurrences of that event to change, including the ones that took place in the past.

i find this to be a major issue if one wants to keep track of things such as bill due dates that occur every month. for example, if one sets a repeating event in January to pay a utility bill on the 12th of every month, and in April the utility company changes that due date to the 9th, the user should have a way to change that recurring date to the 9th on the months following April, while leaving January through March on the 12th of every month as an accurate record of when that bill was due in the past. currently, to change the due date to the 9th from that point forward, the user would have to go back to that initial january occurrence to change the date to the 9th, but that changes january through march's dates to the 9th as well, even though they should remain on the 12th.
Having a "change only future occurrences" button would take care of this, leaving past occurrences untouched, to show an accurate view of what took place back then.

Hope this can be done - this would be a very valuable addition for more than just me, I'm sure.

Thanks,

LJ

Reproducible: Always

Steps to Reproduce:
1.See the details section...
Actual Results:  
See the details section...

Expected Results:  
See the details section...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 320178

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.