z-index doesn't work with overflow

VERIFIED DUPLICATE of bug 39621

Status

()

P3
normal
VERIFIED DUPLICATE of bug 39621
19 years ago
18 years ago

People

(Reporter: andrew.ng, Assigned: jst)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
z-index doesn't seem to work when the overflow attribute is used in a <DIV>.

Example: z-index work w/o overflow
<html>
<body>
<DIV style="background-color:red; HEIGHT:28px; WIDTH:100px; position:absolute; 
top:10px; left:10px; z-index:1"></DIV>
<DIV style="background-color:blue; HEIGHT:14px; WIDTH:100px; position:absolute; 
top:10px; left:10px; z-index:5"></DIV>
</html>

Example: z-index doesn't work w overflow
<html>
<body>
<DIV style="background-color:red; HEIGHT:28px; WIDTH:100px; position:absolute; 
top:10px; left:10px; z-index:1"></DIV>
<DIV style="background-color:blue; HEIGHT:14px; WIDTH:100px; position:absolute; 
top:10px; left:10px; z-index:5; overflow:auto"></DIV>
</html>
(Reporter)

Comment 1

19 years ago

*** This bug has been marked as a duplicate of 39621 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
Component: DOM Level 2 → DOM Style
You need to log in before you can comment on or make changes to this bug.