The default bug view has changed. See this FAQ.

listheader in richlistbox should not scroll

VERIFIED FIXED

Status

()

Toolkit
XUL Widgets
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Hideo Oshima, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 281299 [details]
listheader scrolls away

Bug 391740 has been fixed and listheader in richlistbox
is displayed at correct position.
But if you scroll richlistbox, listheader moves up.
It should not scroll but should stay the top.

Comment 1

10 years ago
    <content>
      <xul:vbox>
      <children includes="listheader"/>
      </xul:vbox>
...

Removing the xul: namespace and enclosing it in a xul:vbox works for
Tools->Options->Applications. I haven't tested it with anything else.

Comment 2

10 years ago
But this fails the first test case in <https://bugzilla.mozilla.org/attachment.cgi?id=276173> since the richlistbox has a default horizontal orientation.

Updated

10 years ago
Duplicate of this bug: 397284

Updated

10 years ago
Depends on: 391740
OS: Linux → All
Hardware: PC → All

Comment 4

10 years ago
fixed by final check-in (bug 391740) on Oct. 11 ?
https://bugzilla.mozilla.org/show_bug.cgi?id=391740#c29

Comment 5

10 years ago
Correct.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 6

10 years ago
Verified fixed in Minefield/3.0a9pre ID:2007101214
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.