Comments containing two consecutive hyphens are not parsed correctly.

RESOLVED DUPLICATE of bug 214476

Status

()

RESOLVED DUPLICATE of bug 214476
11 years ago
11 years ago

People

(Reporter: djain, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Avant Browser; SV1; Avant Browser; .NET CLR 1.0.3705; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

In the presence of a document type definition, Firefox prematurely ends comments that contain two consecutive hyphens (--) at the next greater sign (>) that is encountered. Note that there can be arbitrarily many characters between "--" and ">" in the comment. Everything after the ">" will be rendered even though the comment has not been ended.
The concrete type used in the doctype definition does not seem to matter.

Reproducible: Always

Steps to Reproduce:
Render a page such as this:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html>
<body>
<!-- <a href="x.php?name=foo--bar">error</a> -->
Test.
</body>
</html>
Actual Results:  
In this example, "error --> Test." is rendered.

Expected Results:  
Only "Test." should be rendered.

Other browsers do not exhibit this behaviour.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 214476
You need to log in before you can comment on or make changes to this bug.