If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

export / import the tag root and the unfiled root

VERIFIED FIXED in Firefox 3

Status

()

Firefox
Bookmarks & History
P1
normal
VERIFIED FIXED
10 years ago
7 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: dietrich)

Tracking

Trunk
Firefox 3
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patch in bug 384370])

export / import the tag root and the unfiled root

Dietrich writes:

We certainly do need to worry about this. I've had the backup/restore
on my radar for a while, just haven't been able to get to it. once the
menu UI lands (today), i'm planning on moving on to this.

we currently only import/export the bookmarks root. which means
that the unfiled root and tag root are not being backed up at all,
atm. this is an untenable position.

ideally we could use JSON serialization for this. however, i'm a bit
worried about perf, as we haven't tested large-scale JSON
import/export vs bookmarks HTML format. first thing i'll do is
probably run some tests against large collections to get some ballpark
numbers for this.
Flags: blocking-firefox3?
(Assignee)

Updated

10 years ago
Depends on: 384370
Flags: blocking-firefox3? → blocking-firefox3+
(Assignee)

Comment 1

10 years ago
fix in bug 384370
Assignee: nobody → dietrich
Priority: -- → P1
Target Milestone: --- → Firefox 3 M9
(Assignee)

Updated

10 years ago
Whiteboard: [patch in bug 384370]
pushing this to M10, no native JSON means no bug 384370
Target Milestone: Firefox 3 M9 → Firefox 3 M10

Updated

10 years ago
Priority: P1 → P2
(Assignee)

Updated

10 years ago
Target Milestone: Firefox 3 M10 → Firefox 3 M11

Updated

10 years ago
Priority: P2 → P1
(Assignee)

Updated

10 years ago
Target Milestone: Firefox 3 beta3 → Firefox 3 beta4
(Assignee)

Updated

10 years ago
Duplicate of this bug: 416000
Target Milestone: Firefox 3 beta4 → Firefox 3
(Assignee)

Updated

10 years ago
Duplicate of this bug: 422073
(Assignee)

Comment 5

10 years ago
fixed in bug 384370, though under the backup/restore options. disambiguation of that vs import/export will be fixed in bug 422919.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 6

10 years ago
Verified per 384370
Status: RESOLVED → VERIFIED
Blocks: 393529
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.