Closed Bug 396914 Opened 13 years ago Closed 13 years ago

Prefwindow is corrupted if it has multi panes and contains tree

Categories

(Toolkit :: Preferences, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: gomita, Unassigned)

References

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

600 bytes, image/png
Details
1.09 KB, application/x-xpinstall
Details
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9a8pre) Gecko/2007092005 Minefield/3.0a8pre

xul:prefwindow is corrupted if it has more than two xul:prefpane elements and one of them contains xul:tree.
This is a regression after the checked-in of Bug 283697.

Reproducible: Always
Depends on: 283697
Keywords: regression
Summary: Prefwindow is corrupted if it has multi panes and contains tree. → Prefwindow is corrupted if it has multi panes and contains tree
Version: unspecified → Trunk
Attached file testcase (obsolete) —
Have you tested this on Mac OS X prior to bug 283697 landing?
Reporter, please try reproducing with a recent hourly build or the next nightly build.
Attached image evidence
I tested on the latest hourly 3.0a9pre build but still have same problem.
Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9a8pre) Gecko/2007092119 Minefield/3.0a9pre

And sorry, I've never tested on Mac OS X.
Can you provide the full code that accomplishes this? The testcase throws using the prefwindow since not all of the elements required for the prefwindow are available in the testcase.
A link to download the extension or XULRunner app would be best
I created a testcase as a very simple extension.
Install it, go [Tools] > [Options] > [Testcase], press [Options] button to reproduce the bug.
Attachment #281678 - Attachment is obsolete: true
sorry,
- go [Tools] > [Options] > [Testcase]
+ go [Tools] > [Add-ons] > [Testcase]
I'm unsure when I will be able to look at a possible solution. The one thing that stands out is that the prefwindow requires min-height (preferred on trunk) or height (preferred on branch) to be set for the prefwindow when animateFadeIn is false. If you want to support animateFadeIn (default on Mac OS X and works on all platforms now) you would need to use min-height on trunk. Also, Bug 396121 added the ability to check if animateFadIn is true on the trunk.
I added width, height, min-width and min-height to prefwindow / prefpane elements but still have the problem.
I look at preferences.xml and guess window.sizeToContent(); in line 706 causes the problem.
Just commenting out it and adding return; to the next line seems to solve the problem on Windows and Linux, although the animatedFadeIn is disabled instead.
The bug have been fixed since the following checkins:
http://hourly-archive.localgho.st/win32/20071001_2141_checkins.html
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.