A preference which allows to block cross domain referer data.

RESOLVED DUPLICATE of bug 55477

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 55477
11 years ago
6 years ago

People

(Reporter: jowie.1337, Unassigned)

Tracking

({privacy})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

Normally, Mozilla sends referer headers for every page you got linked to.

This can be undesired for privacy reasons.

There already is network.http.sendRefererHeader=0. However this blocks all referer data.
One example of this being a bad idea is: Referer data inside domains is often used to prevent hotlinking.

For these reasons I am suggesting a preference which blocks cross domain referer data

Reproducible: Always

Steps to Reproduce:
not applicable
Actual Results:  
not applicable

Expected Results:  
not applicable

not applicable

Comment 1

11 years ago
The RefControl extension may do what you want:
https://addons.mozilla.org/de/firefox/addon/953
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: privacy

Updated

6 years ago
Blocks: 822869

Updated

6 years ago
Blocks: 61660

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 55477
You need to log in before you can comment on or make changes to this bug.