Last Comment Bug 397234 - [FIX]Unable to load page http://www.one.lt
: [FIX]Unable to load page http://www.one.lt
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: P5 normal (vote)
: ---
Assigned To: Boris Zbarsky [:bz] (still a bit busy)
:
: Andrew Overholt [:overholt]
Mentors:
http://www.one.lt
Depends on: 393968
Blocks: 382947 398280
  Show dependency treegraph
 
Reported: 2007-09-23 01:57 PDT by Tomas
Modified: 2012-03-10 02:35 PST (History)
13 users (show)
dsicore: blocking1.9+
bzbarsky: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Tomas 2007-09-23 01:57:41 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007092223 Minefield/3.0a9pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007092223 Minefield/3.0a9pre

Page http://www.one.lt doesn't load with any build of FF3. Well, indeed it does: I can see main page for a few second, but then it redirects my to page, saying, that page can't be loaded. There is no problem using FF2 or any other browser.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.one.lt
Actual Results:  
Image http://c19.one.lt/res/images/labels/tmp_close2_lt.gif is showed up in spite of main page.

Expected Results:  
To see main page of http://www.one.lt and be able to browse it.
Comment 1 Tomas 2007-09-23 02:38:17 PDT
Just noticed, that same thing happens with page http://www.videogaga.lt. Both of these pages are build be same developers and, indeed, I think, that it's done pretty bad. So, the problem is bad code of these pages, but on the other side, both of them work OK with FF2 and all other browsers.
Comment 2 Peter van der Woude [:Peter6] 2007-09-23 02:48:40 PDT
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007092216 Minefield/3.0a9pre ID:2007092216

Confirmed, works in IE7 and Opera 9.22

Martijn, can you figure out what's going on here ?
I see a truckload of warnings in the console but none seem to be a reason for the page not properly loading.
Comment 3 Tomas 2007-09-23 03:03:02 PDT
My guess is that problem is connected to CSS of these pages. Firebug shows this errors while loading http://videogaga.lt (while loading http://one.lt I see many more similar errors):

Expected declaration but found '/'. Skipped to next declaration.
[Break on this error] undefined
main.css (line 493)
Error in parsing value for property 'filter'. Declaration dropped.
[Break on this error] undefined
main.css (line 494)
Expected declaration but found '/'. Skipped to next declaration.
[Break on this error] undefined
main.css (line 501)
Error in parsing value for property 'filter'. Declaration dropped.
[Break on this error] undefined
main.css (line 502)
Selector expected. Ruleset ignored due to bad selector.
[Break on this error] undefined
main.css (line 905)
Comment 4 Steve England [:stevee] 2007-09-23 03:07:18 PDT
User Agent sniffing?
Comment 5 Tomas 2007-09-23 03:15:21 PDT
Don't think so. Firstly, I don't see point of developers of these sites to block FF3. Especially, not Firefox in general, but just Firefox 3. Secondly, I've tried "User agent switch" (or something like that) extension, to change user agent. It didn't change a thing about loading these sites.
Comment 7 Peter van der Woude [:Peter6] 2007-09-23 07:15:37 PDT
I'll narrow it down later today
Comment 8 Peter van der Woude [:Peter6] 2007-09-23 07:28:25 PDT
regressionwindow
works in 20070708_1921_firefox-3.0a7pre.en-US.win32
fails in 20070708_1936_firefox-3.0a7pre.en-US.win32

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&filetype=match&whotype=match&sortby=Date&hours=2&date=explicit&mindate=1183947660&maxdate=1183948559&cvsroot=%2Fcvsroot

-> Bug 382947
Comment 9 Martijn Wargers [:mwargers] (not working for Mozilla) 2007-09-27 15:22:34 PDT
As a sidenote, see this page of why it's so difficult to get a testcase out of the page:
http://my.opera.com/hallvors/blog/2007/03/27/how-to-say-hello-world-with-javascript
Comment 10 Boris Zbarsky [:bz] (still a bit busy) 2007-10-02 12:31:31 PDT
Has anyone contacted the site yet?
Comment 11 Damon Sicore (:damons) 2007-11-08 18:14:32 PST
OK.  Let's get to the bottom of this.  +'ing.  Works fine in Fx 2 and Safari.  Moving to DOM.
Comment 12 Tomas 2007-11-11 00:19:09 PST
So it's going to be fixed?
Comment 13 Steve England [:stevee] 2007-11-11 03:47:36 PST
Tomas the problem is going to be investigated. That is no guarantee it will be fixed, but one would hope so.
Comment 14 Boris Zbarsky [:bz] (still a bit busy) 2007-11-11 10:30:11 PST
OK, so the issue here is that we used to send:

  Content-Type: text/plain; charset=utf-8

Now we send:

  Content-Type: text/plain; charset=UTF-8

and this seems to make the site blow up.  Looks a lot like bug 398280 indeed.
Comment 15 Boris Zbarsky [:bz] (still a bit busy) 2007-11-11 11:02:42 PST
I think the right fix here is to leave the existing charset if it matches the one we want to set (up to case).  I'll probably roll that change into the fix for bug 393968.
Comment 16 Boris Zbarsky [:bz] (still a bit busy) 2007-12-03 13:38:24 PST
Fixed by checkin for bug 393968.  Checked in a test too.
Comment 17 Julian Reschke 2011-11-16 05:21:23 PST
See tests in <http://lists.w3.org/Archives/Public/public-webapps/2011OctDec/0955.html>. It appears that, as of 2011, only FF tries to preserve the charset casing (where Opera and IE preserve it because they do not fix the charset at all).
Comment 18 Boris Zbarsky [:bz] (still a bit busy) 2011-11-16 16:52:01 PST
Yes, but the upshot is that for pages that set the charset the three have compat.

If course you can try backing this patch out and seeing whether this site breaks, as well as the site in bug 398280.
Comment 19 Julian Reschke 2012-03-10 02:33:42 PST
See related XHR issue: https://www.w3.org/Bugs/Public/show_bug.cgi?id=16302
Comment 20 Julian Reschke 2012-03-10 02:35:37 PST
(In reply to Julian Reschke from comment #19)
> See related XHR issue: https://www.w3.org/Bugs/Public/show_bug.cgi?id=16302

Sorry, wrong link.

https://www.w3.org/Bugs/Public/show_bug.cgi?id=16303

Note You need to log in before you can comment on or make changes to this bug.