Closed Bug 397302 Opened 13 years ago Closed 11 years ago

ESC key should stop all animations, including flash animations. Escape/Stop/GIF

Categories

(Core :: Plug-ins, enhancement)

x86
Linux
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 11875

People

(Reporter: bryce2, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20070719 SUSE/1.1.3-0.1 SeaMonkey/1.1.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20070719 SUSE/1.1.3-0.1 SeaMonkey/1.1.3

One of the best mozilla features has been the ability to stop endless loop animations. But it's not working with Seamonkey for Flash animations.

If a simple tap of the ESC key would stop all animations, flash included, all our lives would be just a tiny bit better.

Reproducible: Always
Note: there are several open bugs about GIF animations, but I could not find one specifically addressing flash animation.
Perhaps the flash process could simply be starved of CPU cycles?  Or starved of window refresh events?

* I have no desire to uninstall flash.
* I have no desire to block flash.
* But I don't want flash animations to hog my CPU, and distract from reading.
* And still want to be able to play or view a particular flash content, if it is of interest to me.

Without some browser based solution to this issue (because this type of feature won't come from Macromedia), the web is getting less useful.  I leave flash based sites regularly.

Flash needs to be put back into the box from which it came, lest it be used for evil (Google "Flash is evil").
Assignee: general → nobody
Component: General → Plug-ins
Product: Mozilla Application Suite → Core
QA Contact: general → plugins
Version: unspecified → Trunk
See Suite bug 11875 and Firefox bug 267141.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 11875
You need to log in before you can comment on or make changes to this bug.