If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Make &state=disabled work again

RESOLVED FIXED in mozilla1.9beta1

Status

()

Core
ImageLib
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: micmon, Assigned: Michael Ventnor)

Tracking

Trunk
mozilla1.9beta1
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

943 bytes, patch
Biesinger
: review+
Biesinger
: superreview+
Stuart Parmenter
: approval1.9+
Details | Diff | Splinter Review
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20061201 Firefox/2.0.0.3 (Ubuntu-feisty)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20061201 Firefox/2.0.0.3 (Ubuntu-feisty)

For perfect OS integration on Linux/GNOME it would be very nice if we could create a theme that always picks up the icons from the GTK icon theme.

This is possible today, by using moz-icon://stock/*. The only problem so far is that I am unable to create the disabled state of buttons, because there is no way to display a button in grayscale and XUL doesn't seem to do this itself (when the button is "disabled").

Now, creating separate icons for disabled stats would be possible, but it also defeats the whole purpose of this. So, would it be possible to provide a "-moz-disabled" property, similar to -moz-opacity, which draws the icon with less saturation to make it look gray/disabled?

Reproducible: Always
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
(Assignee)

Comment 1

10 years ago
Just add &state=disabled to the end of the icon URL, but it is broken at the moment. This is actually because of a typo I found in the code  a little while ago, I have a patch for it coming up.
(Assignee)

Comment 2

10 years ago
Created attachment 284791 [details] [diff] [review]
Patch

Simple typo, trivial patch, we're only human.
Assignee: nobody → ventnor.bugzilla
Status: NEW → ASSIGNED
Attachment #284791 - Flags: superreview?(pavlov)
Attachment #284791 - Flags: review?(pavlov)
Severity: enhancement → normal
Component: OS Integration → ImageLib
Product: Firefox → Core
QA Contact: os.integration → imagelib
Summary: Add a way to grayscale icon → Make &state=disabled work again
Attachment #284791 - Flags: superreview?(pavlov)
Attachment #284791 - Flags: superreview+
Attachment #284791 - Flags: review?(pavlov)
Attachment #284791 - Flags: review+
(Assignee)

Updated

10 years ago
Attachment #284791 - Flags: approval1.9?

Updated

10 years ago
Attachment #284791 - Flags: approval1.9? → approval1.9+
(Assignee)

Updated

10 years ago
Keywords: checkin-needed
Checking in modules/libpr0n/decoders/icon/nsIconURI.cpp;
/cvsroot/mozilla/modules/libpr0n/decoders/icon/nsIconURI.cpp,v  <--  nsIconURI.cpp
new revision: 1.28; previous revision: 1.27
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M9
You need to log in before you can comment on or make changes to this bug.