[exceptionfree] Crash completing forms debugging with Venkman [@ nsAutoCompleteController::EnterMatch]

RESOLVED DUPLICATE of bug 384879

Status

()

RESOLVED DUPLICATE of bug 384879
11 years ago
7 years ago

People

(Reporter: asrail, Unassigned)

Tracking

({assertion, crash})

Trunk
x86
Linux
assertion, crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Created attachment 282200 [details]
Stack trace

Autocomplete forms works very well here, but it crashes while using the option "Stop for exceptions" of Venkman.

Steps:
 1 - Open Venkman
 2 - Check "Debug --> Throw Trigger --> Stop for Exceptions"
 3 - Uncheck "Exclude Browser Files"
 4 - Type your name on the 'Name' field
 5 - Preview a empty comment here: http://weblogs.mozillazine.org/weirdal/archives/018562.html
 6 - Back
 7 - Start typing your name one the 'Name' field
 8 - Press the down key
 9 - Press tab
10 - Hit 'continue' on Venkman

It will crash...

nothing personal with Alex, but I got the crash in that page ;).
(Reporter)

Comment 1

11 years ago
Created attachment 282201 [details]
More assertions (GC)

I had missed those assertions, but now it looks it's clearly a cycle collector related bug.
(Reporter)

Updated

11 years ago
Blocks: 333078
(Reporter)

Updated

11 years ago
Whiteboard: [exceptionfree]

Updated

11 years ago
Whiteboard: [exceptionfree] → [exceptionfree] DUPEME
I doubt this is cycle collector related. The assertions from the cycle collector were fixed in bug 401687, but they wouldn't cause a crash. Things would just leak more.
Blocks: 401687
No longer blocks: 333078

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Whiteboard: [exceptionfree] DUPEME
Duplicate of bug: 384879
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsAutoCompleteController::EnterMatch]
You need to log in before you can comment on or make changes to this bug.