searching in bookmarks (without restricting the folder) ends up with duplicates due to the tag root

RESOLVED DUPLICATE of bug 397165

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 397165
11 years ago
9 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

searching in bookmarks (without restricting the folder) ends up with duplicates due to the tag root

in bug #393464, marcia wrote:

when I tag the espn.go.com home page with "sports" and then
search for "sports" in organize bookmarks. This happens when I tagged other
sites as well - I always seem to get two entries that come up.

in bug #393464, michael writes:

This has been thus since tags hit the trunk. I saw it when I searched bookmarks
for "/" to see the infamous invisible "all bookmarks". You get one "no title"
entry per tag, plus the titled original. The untitleds show up in the bookmarks
table, as I recall, as children of the tags, one row per child.

I just assumed it was due to the lack of UI at the time, and they'd be hidden
from view once tags were functional, so I didn't file a bug.
Flags: blocking-firefox3?
we want searching to find tagged items, but for the special "places" menu items (see bug #387996), we might be able to deal with this by limiting our query to all bookmarks root and the unfiled root, and therefore exclude (by omission) the tag root.  but this doesn't seem like a great approach.  we could add support to explictly exclude certain folders.

but note, for general searching, we want to search the tag root, but we don't want to show blank titles.  bug #387996 has some code for getting titles for tags.

note, that would still result in duplicate items.  we could collapse duplicates, but that is notoriously slow if you do that in treeView.js, so I would look for a different solution.
mano has already fixed this, as he's fixed it by explictly limiting queries to the all bookmarks root and the unfiled root.

I'll go do the same for bug #387996.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 397165
Flags: blocking-firefox3?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.