Closed Bug 397476 Opened 14 years ago Closed 14 years ago

Memory leaks in pointer tracker code in DEBUG builds only

Categories

(NSS :: Libraries, defect, P2)

Sun
Solaris
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 370536

People

(Reporter: slavomir.katuscak+mozilla, Unassigned)

Details

(Keywords: memory-leak)

Memory leaks in trust domain: 

Block in use (biu):
Found block of size 88 bytes at address 0x8175a48 (2.64% of total)
At time of allocation, the call stack was:
    [1] calloc() at 0xb4d308a0 
    [2] PR_Calloc() at line 475 in "prmem.c"
    [3] PR_NewLock() at line 174 in "ptsynch.c"
    [4] myOnceFunction() at line 89 in "tracker.c"
    [5] PR_CallOnce() at line 815 in "prinit.c"
    [6] call_once() at line 123 in "tracker.c"
    [7] nssPointerTracker_initialize() at line 233 in "tracker.c"
    [8] arena_add_pointer() at line 139 in "arena.c"
    [9] nssArena_Create() at line 447 in "arena.c"
    [10] NSSArena_Create() at line 386 in "arena.c"
    [11] NSSTrustDomain_Create() at line 90 in "trustdomain.c"
    [12] STAN_LoadDefaultNSS3TrustDomain() at line 140 in "pki3hack.c"
    [13] nss_Init() at line 499 in "nssinit.c"
    [14] NSS_Initialize() at line 614 in "nssinit.c"
    [15] main() at line 1915 in "selfserv.c"

Block in use (biu):
Found block of size 88 bytes at address 0x8175ae8 (2.64% of total)
At time of allocation, the call stack was:
    [1] calloc() at 0xb4d308a0
    [2] PR_Calloc() at line 475 in "prmem.c"
    [3] PR_NewLock() at line 174 in "ptsynch.c"
    [4] trackerOnceFunc() at line 186 in "tracker.c"
    [5] call_once() at line 131 in "tracker.c"
    [6] nssPointerTracker_initialize() at line 233 in "tracker.c"
    [7] arena_add_pointer() at line 139 in "arena.c"
    [8] nssArena_Create() at line 447 in "arena.c"
    [9] NSSArena_Create() at line 386 in "arena.c"
    [10] NSSTrustDomain_Create() at line 90 in "trustdomain.c"
    [11] STAN_LoadDefaultNSS3TrustDomain() at line 140 in "pki3hack.c"
    [12] nss_Init() at line 499 in "nssinit.c"
    [13] NSS_Initialize() at line 614 in "nssinit.c"
    [14] main() at line 1915 in "selfserv.c"

Block in use (biu):
Found block of size 32 bytes at address 0x8175b58 (0.96% of total)
At time of allocation, the call stack was:
    [1] PR_Malloc() at line 467 in "prmem.c"
    [2] DefaultAllocTable() at line 72 in "plhash.c"
    [3] PL_NewHashTable() at line 129 in "plhash.c"
    [4] trackerOnceFunc() at line 196 in "tracker.c"
    [5] call_once() at line 131 in "tracker.c"
    [6] nssPointerTracker_initialize() at line 233 in "tracker.c"
    [7] arena_add_pointer() at line 139 in "arena.c"
    [8] nssArena_Create() at line 447 in "arena.c"
    [9] NSSArena_Create() at line 386 in "arena.c"
    [10] NSSTrustDomain_Create() at line 90 in "trustdomain.c"
    [11] STAN_LoadDefaultNSS3TrustDomain() at line 140 in "pki3hack.c"
    [12] nss_Init() at line 499 in "nssinit.c"
    [13] NSS_Initialize() at line 614 in "nssinit.c"
    [14] main() at line 1915 in "selfserv.c"

Found in standard test (connection from strsclnt to selfserv). 
Variable NSS_DISABLE_ARENA_FREE_LIST was set to 1.
Priority: -- → P2
Summary: Memory leaks in trust domain. → Memory leaks in pointer tracker code in DEBUG builds only
One thing I noticed is that there are no calls to nssPointerTracker_finalize()
Let's be careful to not file duplicate leak bugs.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 370536
You need to log in before you can comment on or make changes to this bug.