XUL color pickers are inaccessible

RESOLVED DUPLICATE of bug 291518

Status

()

Core
Disability Access APIs
RESOLVED DUPLICATE of bug 291518
11 years ago
11 years ago

People

(Reporter: Joanmarie Diggs, Assigned: Aaron Leventhal)

Tracking

(Blocks: 2 bugs, {access})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Steps to reproduce:

1. Launch Accerciser and Firefox

2. In Firefox navigate to Preferences->Content and press the Colors button.

3.  In the resulting Colors dialog, tab to the background color picker.  Then examine it in Accerciser.

4.  Turn event monitoring on in Accerciser.  Then press the space bar in the color picker and arrow around to choose a color.

Expected Results:  In step 3 there would be a meaningful role name, the selected color would be exposed, perhaps the color choices would be children of color picker, etc.  In step 4, there would be meaningful events (focus, selection changed, whathaveyou) exposed as one arrowed from color to color.

Actual Results:  The color picker has ROLE_UNKNOWN, the selected color is not exposed, the color picker has no children.  We do get focus events, but no details exposed to let us know the color with focus.

Users with low vision who require speech/braille, but who also benefit from being able to customize their colors, will find this widget especially problematic.

Comment 1

11 years ago
It is <colorpicker />.

Updated

11 years ago
Blocks: 368875
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 291518
You need to log in before you can comment on or make changes to this bug.