Closed Bug 397644 Opened 13 years ago Closed 13 years ago

input type="file" not exposed correctly

Categories

(Core :: Disability Access APIs, defect, major)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: steve, Assigned: aaronlev)

References

Details

(Keywords: access, regression)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007092404 Minefield/3.0a9pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007092404 Minefield/3.0a9pre

An input file is show as a role=text and does not have STATUS_FOCUSABLE.
in addition it has no action interface (it should have Press)

Reproducible: Always

Steps to Reproduce:
1.open a page with a input type="file"
2.use accerciser to view the accessible and action interfaces
3.



The are other design issues with input type="file" but these problem need fixing whatever. See 345195
Blocks: fox3access
Severity: normal → major
Keywords: access
Keywords: regression
i'm not even getting role_text, I get a BSTR role of input. I guess the file input control is totally broken for accessibility.
Also, the Browse... button fires events but I don't see it in the top-down hierarchy.
This is a special case fix for file controls, which returns things to how they were before we removed our broken :before/:after accessible object support.

Although special casing file control here is not pretty, it's good because it is not risky and time is short for Firefox 3. I think this is the best thing for now.

We may do more frame walking later for controls with anon content.
We also may no longer need to do this if Firefox moves to a mac-like file control. It's not yet clear.
Attachment #282563 - Flags: superreview?(roc)
Attachment #282563 - Flags: review?(roc)
Comment on attachment 282563 [details] [diff] [review]
1) Don't create accessible for file control frame itself (nsBlockFrame::GetAccessible() generically creates accessibles now), and 2) Revert to frame walking to find accessibles for input type="file"

Correct patch coming up.
Attachment #282563 - Attachment is obsolete: true
Attachment #282563 - Flags: superreview?(roc)
Attachment #282563 - Flags: review?(roc)
Attached patch Correct patchSplinter Review
Attachment #282571 - Flags: superreview?(roc)
Attachment #282571 - Flags: review?(roc)
Attachment #282571 - Flags: superreview?(roc)
Attachment #282571 - Flags: superreview+
Attachment #282571 - Flags: review?(roc)
Attachment #282571 - Flags: review+
Attachment #282571 - Flags: approval1.9+
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
I would have special accessible class than to burden nsAccessibleTreeWalker
Surkov, we can do that after FF3. This was low risk because it worked this way before.
(In reply to comment #7)
> Surkov, we can do that after FF3. This was low risk because it worked this way
> before.
> 

Sure, I don't mind just should we have bug to track it?
You need to log in before you can comment on or make changes to this bug.