All users were logged out of Bugzilla on October 13th, 2018

populate actions dropdown in Applications prefpane with possible local handlers

REOPENED
Unassigned

Status

()

--
enhancement
REOPENED
11 years ago
11 years ago

People

(Reporter: myk, Unassigned)

Tracking

Trunk
x86
Other
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Once bug 348808 lands, we should populate the actions dropdown menu in the Applications prefpane with the list of possible local handlers (i.e. handlers that the OS says can handle the type), since that gives users more immediate access to a set of handlers for the type.
Requesting blocking or [wanted-firefox3].
Assignee: nobody → dmose
Flags: blocking-firefox3?
Really-really want, potentially even moving up to blocking sometime in the future depending on what things look like without it. 

Should we also have an entry for "System default (appName)" which would just call the default OS handler?
Flags: blocking-firefox3? → blocking-firefox3-
Whiteboard: [wanted-firefox3]
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> Should we also have an entry for "System default (appName)" which would just
> call the default OS handler?

Yup, we have that already.  We don't label it as the "system default", but if the system has a default handler for a type, we list that application first in the list of applications.
>We don't label it as the "system default", but if
>the system has a default handler for a type, we list that application first in
>the list of applications.

I think this is the way to go, since I'm pretty sure the majority of users don't have a very solid mental model of the difference between their OS and third party applications.

The next step is to mirror changes made here back to the system settings, but that is more likely Firefox 4-ish.
Flags: wanted-firefox3+
Whiteboard: [wanted-firefox3]
With a few exceptions, I'm mostly focused on MailCo-related hacking now.  Reassigning a bunch of bugs to default component owners.  I'm happy to help with brainstorming/advice as needed, however.  

Search for the string MAILMONKEY to delete any bugmail generated by this change.
Assignee: dmose → nobody

Updated

11 years ago
OS: Windows XP → Other

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 370380
This is not a DUP of bug 370380.  Both this bug _AND_ that bug should be fixed.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
You need to log in before you can comment on or make changes to this bug.