Closed Bug 397709 Opened 12 years ago Closed 8 years ago

give javascript executing in background tabs less priority

Categories

(Core :: General, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 712731

People

(Reporter: moco, Unassigned)

References

(Blocks 3 open bugs)

Details

(Keywords: perf, Whiteboard: [Snappy])

give javascript executing in background tabs less priority

for example, say I have something that does a ton of js in tab, but that tab is in a background tab or a minimized window.  can we give more priority to js in the chrome or in the currently focused tab?

brendan, would something like this even be possible?

see also bug #336060:   Use a slower idleEvent timer for plugins that are not in a foreground tab on the key window

see also bug #341046:  "Incremental layout should not happen in background tabs"
Product: Firefox → Core
QA Contact: general → general
Blocks: 384323
Keywords: perf
Blocks: 595574
Daniel, do you think this is a common enough problem to be tracked for snappy project? Is it possible that smaller/simpler SVGs also cause annoying stalls? Is this something that we can easily add telemetry probes for?
Component: General → SVG
QA Contact: general → general
Whiteboard: [Snappy]
sorry, commented in wrong bug
Component: SVG → General
QA Contact: general → general
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 712731
You need to log in before you can comment on or make changes to this bug.