Download Manager doesn't update itself when DL History gets cleared via Tools -> Clear Private Data

VERIFIED DUPLICATE of bug 392152

Status

()

Toolkit
Downloads API
--
minor
VERIFIED DUPLICATE of bug 392152
11 years ago
10 years ago

People

(Reporter: Stefan Breunig, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007092605 Minefield/3.0a9pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007092605 Minefield/3.0a9pre

1. Have the download manager open with at least one finished file in the history
2. Open a browser window and select Tools -> Clear Private Data (on Windows, might be located elsewhere on Mac/Linux)
3. Check to clear download history
4. Look at Download Manger -- History still there

After closing and reopening the DM the history is gone, so it's not a history problem. 
I've no idea if it's possible, but it sounds reasonable to have the DM listen to (download) history changes and update when needed.

Reproducible: Always

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392152
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.