CFLAGS specified to configure (HOST_CFLAGS) are ignored in too many cases (M15)

VERIFIED INVALID

Status

P3
normal
VERIFIED INVALID
19 years ago
14 years ago

People

(Reporter: mi+mozilla, Assigned: cls)

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
During a FreeBSD port build of mozilla (or any other port), the desired CC, CXX,
CFLAGS, and CXXFLAGS are passed to the configure script in the environment.

The configure seems to aknowledge them:
[...]
configure:1874: checking whether the C compiler (cc -O -pipe -mcpu=i686 -march=i
686 -fexpensive-optimizations ) works
configure:1890: cc -o conftest -O -pipe -mcpu=i686 -march=i686 -fexpensive-optim
izations   conftest.c  1>&5
configure:1916: checking whether the C compiler (cc -O -pipe -mcpu=i686 -march=i
686 -fexpensive-optimizations ) is a cross-compiler
[...]

and they are indeed used to compile SOME of the source files, but far not
all of them.

The easiest way to test this is to run configure as:
	env CFLAGS='..whatever you use.. -DHAIRY_BLUE_FLAMINGO' ./configure
then do
	gmake |& tee log
and grep the log for the weird bird...
(Assignee)

Comment 1

19 years ago
Mikhail, the only files that I know of that would not use the passed in CFLAGS
are in NSPR.  Can you actually post a small list of the files affected? (I'd
test but my normal build hosts are down at them moment). I don't understand the
reference to HOST_CFLAGS in the subject.

Comment 2

19 years ago
this is a 'dead' bug and has sat for over a month in unconfirmed waters...I'm 
temporarily resolving as invalid for now because we haven't heard back from the 
reporter in over a month, either to confirm that this still happens or to 
answer any of cls's questions...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 3

19 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.