Firefox core dumps [@ libpthread.so.0 + 0x9630 - mplayerplug-in.so + 0x145fa]

RESOLVED INVALID

Status

Plugins Graveyard
Mplayer
--
critical
RESOLVED INVALID
11 years ago
2 years ago

People

(Reporter: Tibor Nagy, Unassigned)

Tracking

({crash})

Details

(crash signature, URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; hu; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; hu; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

Firefox makes a core dump if the home page http://www.telmex.hu/ is opened and after that closed. It happens also in --safe-mode. The following message appears on the console:
----------------------------------------------------
(Gecko:6827): Gtk-CRITICAL **: gtk_widget_set_size_request: assertion `height >= -1' failed

(Gecko:6827): Gtk-CRITICAL **: gtk_widget_set_size_request: assertion `height >= -1' failed

(Gecko:6827): Gtk-CRITICAL **: gtk_widget_set_size_request: assertion `height >= -1' failed
/opt/firefox/run-mozilla.sh: line 131:  6827 Szegmens hiba           "$prog" ${1+"$@"}

-------------------------------------------------------
Szegmens hiba = segmentation fault (in hungarian).
The GTK messages appear at opening the home page.
The core file is 1.8GB(!!!) and basically filled with "0", so I guess it's
about wrong memory allocation. The bzib2 compressed core file is only 5MB.


Reproducible: Always

Steps to Reproduce:
1. Start firefox (normal or safe mode)
2. Go to http://www.telmex.hu/
3. Close firefox



I must say that firefox 2.x is very unstable, but the crashes are mostly not reproducable. I had no major problem with firefox 1.x.

I have a Talkback crash ID also, I must exit and start firefox again. I'll attach it later.
(Reporter)

Comment 1

11 years ago
The Talkback incident IDs:

TB36510356K
TB36509505Y

I have also the core file, but it is to big to attach here.

(Reporter)

Comment 2

11 years ago
Other way to Reproduce:
1. Start firefox (normal or safe mode)
2. Go to http://www.telmex.hu/
3. Go to any other home page
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0 Branch
mplayerplug-in.so seems to cause this crash. Can you please remove if and try it again ?
(Reporter)

Comment 4

11 years ago
Matthias, you are right, after removing the mplayer plugin, firefox does not crash.
By the way, are the plugins not switched off in safe mode?
Does it mean, that it is an mplayer problem?
Only addons and Themes are disabled with the safemode but not plugins.
And yes, it's mplayer that is causing this crash.You can see that in the stacktrace from the talkback crash and of course that it works if you disable the plugin.

Please ask the mplugin developers for help (and yes, we have already a bug that a plugin should not be able to crash the browser).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Comment 6

11 years ago
Incident ID: 36509505
Stack Signature	libpthread.so.0 + 0x9630 (0xb3a17630) e59b343b
Product ID	Firefox2
Build ID	2007091417
Trigger Time	2007-10-02 03:32:32.0
Platform	LinuxIntel
Operating System	Linux 2.6.16.27-0.6-default
Module	libpthread.so.0 + (00009630)
URL visited	http://www.telmex.hu
User Comments	Firefox was started from thunderbird with the link http://www.telmex.hu/ after tahat I closed only the window.
Since Last Crash	0 sec
Total Uptime	5 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	N/A
Stack Trace 	
libpthread.so.0 + 0x9630 (0xb3a17630)
mplayerplug-in.so + 0x145fa (0x74a195fa)
mplayerplug-in.so + 0x11374 (0x74a16374)
mplayerplug-in.so + 0x115d8 (0x74a165d8)
mplayerplug-in.so + 0x13ad3 (0x74a18ad3)
ns4xPluginInstance::Stop()  [mozilla/modules/plugin/base/src/ns4xPluginInstance.cpp, line 965]
nsObjectFrame::Destroy()  [mozilla/layout/generic/nsObjectFrame.cpp, line 830]
Component: General → Plug-ins
Keywords: crash
Product: Firefox → Core
Summary: Firefox core dumps → Firefox core dumps [@ libpthread.so.0 + 0x9630 - mplayerplug-in.so + 0x145fa]
Version: 2.0 Branch → 1.8 Branch

Updated

8 years ago
Component: Plug-ins → Mplayer
Product: Core → Plugins
QA Contact: general → mplayer
Version: 1.8 Branch → unspecified
(Assignee)

Updated

7 years ago
Crash Signature: [@ libpthread.so.0 + 0x9630 - mplayerplug-in.so + 0x145fa]
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.