[FIX]Disallow reflow while processing constructors

RESOLVED FIXED

Status

()

Core
XBL
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: bz, Assigned: bz)

Tracking

({dev-doc-complete, fixed1.8.1.8})

1.8 Branch
x86
Linux
dev-doc-complete, fixed1.8.1.8
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8.1.8 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: restore pre-267833 status quo to prevent regressions)

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
See bug 375390 comment 24.

I'll try to get a patch together today.
Flags: blocking1.8.1.8?
If you only have time for one I'd prefer a branch patch for bug 387544
(Assignee)

Comment 2

10 years ago
To be honest, that one is a _lot_ more work and needs pretty extensive testing for any patch we come up with.  See bug 387544 comment 1.  It shouldn't be going in this close to the end of a branch cycle.  :(
(Assignee)

Comment 3

10 years ago
Created attachment 283411 [details] [diff] [review]
Fix (branch only)
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Attachment #283411 - Flags: superreview?(dbaron)
Attachment #283411 - Flags: review?(dbaron)
(Assignee)

Updated

10 years ago
Summary: Disallow reflow while processing constructors → [FIX]Disallow reflow while processing constructors
Comment on attachment 283411 [details] [diff] [review]
Fix (branch only)

r+sr=dbaron
Attachment #283411 - Flags: superreview?(dbaron)
Attachment #283411 - Flags: superreview+
Attachment #283411 - Flags: review?(dbaron)
Attachment #283411 - Flags: review+
(Assignee)

Comment 5

10 years ago
Comment on attachment 283411 [details] [diff] [review]
Fix (branch only)

Requesting branch approval.  I think this should be pretty safe in the sense that it restores the status quo before bug 267833 was checked in.
Attachment #283411 - Flags: approval1.8.1.8?
Comment on attachment 283411 [details] [diff] [review]
Fix (branch only)

approved for 1.8.1.8, a=dveditz for release-drivers
Attachment #283411 - Flags: approval1.8.1.8? → approval1.8.1.8+
Flags: blocking1.8.1.8? → blocking1.8.1.8+
Whiteboard: restore pre-267833 status quo to prevent regressions
(Assignee)

Comment 7

10 years ago
Checked in on branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: fixed1.8.1.8
Resolution: --- → FIXED
(Assignee)

Comment 8

10 years ago
We should document the change from branch to trunk here: on trunk, trying to get layout information in an XBL constructor will actually get up-to-date information, triggering restyles and reflow as needed.  On branch you don't get that.
Keywords: dev-doc-needed
This is now documented.  See:

http://developer.mozilla.org/en/docs/XBL:XBL_1.0_Reference:Elements#constructor

Marking as doc completed.

Is this going into some build of Firefox 2?  I ask because of the approval for 1.8.1.8.  If so, which Firefox version does it apply to?
Keywords: dev-doc-needed → dev-doc-complete
(Assignee)

Comment 10

10 years ago
> Is this going into some build of Firefox 2?

The patch that went into the branch was to restore the old branch behavior (not allowing reflow inside a constructor).  So there's no need for branch documentation changes here.
You need to log in before you can comment on or make changes to this bug.