If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Task list: Priority icon not visible if task is selected due to row background color

VERIFIED FIXED in 0.8

Status

Calendar
Tasks
--
trivial
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Tom Spalango, Assigned: Lars Wohlfahrt (thetux))

Tracking

unspecified

Details

Attachments

(4 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: Sunbird v0.7, rv: 1.8.1.8pre, Gecko/20071002

Cosmetic only.

When you highlight a task it reverses the colors based on the due date of the task.  For example, if there is no due date the normal text is grey and the background is white for that entry.  When you click on it, the text becomes white and the background becomes grey.  It seems the Importance Flag (either the exclamation point for High or the down arrow for Low) is completely ignored.

This does not become an issue with display at all until there is a past due (red) task and an importance flag of High (red exclamation point)

When you select the task, the background becomes red and the text becomes white, reversing as it should, however the importance flag remains red and therefore is "invisible" if you have the task highlighted.

Reproducible: Always

Steps to Reproduce:
1. Create a task, make the due date is right now.
2. Click on Options, Importance and make it High.
3. Save and close the task.  This task will appear on the Tasks list with a white background and red text, as well as a red exclamation point next to it.
3. Left click on the task in the Tasks list.
Actual Results:  
The color of the task's name reverses properly however the importance flag is ignored.

Expected Results:  
Use a different icon for when it is selected in this state, either reverse the color of the exclamation point also to white or outline it in some way to show that there is an exclamation point there.

Default.

Comment 1

10 years ago
Confirmed using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.8pre) Gecko/20071016 Sunbird/0.7.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: Tasks Importance Flag does not reverse in color → Task list: Priority icon not visible if task is selected due to row background color

Comment 2

10 years ago
Created attachment 285246 [details]
screenshot showing issue

Comment 3

10 years ago
Does apply to latest Lightning 0.8pre (build 2008022218)
(Assignee)

Updated

10 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

10 years ago
Assignee: nobody → thetux.moz
Status: ASSIGNED → NEW
(Assignee)

Comment 4

10 years ago
Created attachment 306810 [details]
Priority High inverse colors (needs to be in calendar/base/themes/common)
(Assignee)

Comment 5

10 years ago
Created attachment 306811 [details]
Priority Low inverse colors (needs to be in calendar/base/themes/common)
(Assignee)

Comment 6

10 years ago
Created attachment 306812 [details] [diff] [review]
Patch to fix the color issues of selected rows for the priority images

Needs the files priority_high_inverse.png and priority_low_inverse.png in calendar/base/themes/common
Attachment #306812 - Flags: review?
(Assignee)

Updated

10 years ago
Attachment #306812 - Flags: review? → review?(philipp)
Attachment #306812 - Attachment is patch: true
Attachment #306812 - Attachment mime type: application/octet-stream → text/plain
Comment on attachment 306812 [details] [diff] [review]
Patch to fix the color issues of selected rows for the priority images

>+	skin/classic/calendar/priority_high_inverse.png (themes/common/priority_high_inverse.png)
>+	skin/classic/calendar/priority_low_inverse.png (themes/common/priority_low_inverse.png)
Please expand tabs to 4 spaces in following patches. I'll do so before checkin, no further patch required.

r=philipp, nice work :-)
Attachment #306812 - Flags: review?(philipp) → review+
Comment on attachment 306810 [details]
Priority High inverse colors (needs to be in calendar/base/themes/common)

images require ui-review
Attachment #306810 - Flags: ui-review?(christian.jansen)

Comment 9

10 years ago
Comment on attachment 306812 [details] [diff] [review]
Patch to fix the color issues of selected rows for the priority images

looks good, thanks for the icons. r=christian
Attachment #306810 - Flags: ui-review?(christian.jansen) → ui-review+
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.8

Comment 11

10 years ago
Checked in nightly build 2008030318 -> task is fixed and verified. 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.