Closed Bug 398439 Opened 14 years ago Closed 9 years ago

Hard to see the difference between level1 and level2 headings in wiki.mozilla.org

Categories

(Websites :: wiki.mozilla.org, defect)

x86
macOS
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: djst, Unassigned)

Details

In the wiki, the following heading levels look almost identical with the current CSS:

= Heading 1 =
== Heading 2 ==

This makes it hard to follow the structure of a page using both heading levels.
He's right, please someone change the status of this bug to CONFIRMED.  The CSS sets h1 to 160% of normal and h2 is 140% of normal.  At regular zoom on my display they're only 1 pixel different in height, too close.

One fix is to change https://www.mozilla.org/css/cavendish/content.css, making h2 smaller:

	h1 { font-size: 160%; font-weight: normal; }
-	h2 { font-size: 150%; font-weight: normal; }
+	h2 { font-size: 140%; font-weight: normal; }
	h3 { font-size: 120%; }
	h4 { font-size: 100%; }
	h5 { font-size: 90%; }

or you could make h1 bigger, e.g. 170%.

Note that Firebug indicates the 140% sizing of h3 here is actually overridden by https://wiki.mozilla.org/skins/cavendish/main.css which sets
h3 {
	font-size: 1.3em;
	font-weight: bold;
}

so the CSS is sizing the headings two different ways.  Clean-up opportunity.


In general MediaWiki markup should not use the =Heading 1= level, since h1 is the level the page title gets.
Component: other.mozilla.org → wiki.mozilla.org
QA Contact: other-mozilla-org → wiki-mozilla-org
This is an ancient bug and is no longer applicable.  I would close it if I had permission to.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.