Closing a tab doesn't call nsFormFillController's nsIDOMEventListener with a "pagehide" event

RESOLVED DUPLICATE of bug 376563

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 376563
10 years ago
10 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Over in bug 397753 Martijn noted that closing a tab will cause the following alert to be triggered in a test page:

<body onpagehide="alert('test');"></body>

[The code is also called when navigating away from the page.]

nsFormFillController has a nsIDOMEventListener implementation listening for this event too. It gets called when the page is navigated away from, but not when the tab is closed.

Also of potential interest: bug 376563, where nsFormFillController's ::Unload code isn't getting called.
(Reporter)

Comment 1

10 years ago
This looks to have the same root cause as bug 376563... The window listeners were being removed before being called. Doh.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376563
You need to log in before you can comment on or make changes to this bug.