Closed Bug 398510 Opened 13 years ago Closed 13 years ago

[FIX]Crash [@ IsPercentageAware] removing text from mtd with :first-letter

Categories

(Core :: MathML, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla1.9beta2

People

(Reporter: jruderman, Assigned: bzbarsky)

References

(Blocks 2 open bugs)

Details

(Keywords: assertion, crash, testcase)

Crash Data

Attachments

(2 files)

Loading the testcase triggers a crash [@ IsPercentageAware], with an assertion warning about the impending crash.

###!!! ASSERTION: null frame is not allowed: 'aFrame', file /Users/jruderman/trunk/mozilla/layout/generic/nsLineLayout.cpp, line 712
We have a first-letter frame with no textframe inside.  Shouldn't really be happening...
Attached patch FixSplinter Review
The issue is that we assume first-letter only happens on float containing blocks, and MathML is violating this assumption.  Fix is to not allow first-letter on MathML cell inners.
Attachment #283809 - Flags: superreview?(roc)
Attachment #283809 - Flags: review?(rbs)
Assignee: rbs → bzbarsky
OS: Mac OS X → All
Priority: -- → P2
Hardware: PC → All
Summary: Crash [@ IsPercentageAware] removing text from mtd with :first-letter → [FIX]Crash [@ IsPercentageAware] removing text from mtd with :first-letter
Target Milestone: --- → mozilla1.9 M10
Boris, this is probably fixed by my patch to wrap non-MathML children of MathML in blocks, do you want this patch in any case?
Yes, I think we still need this patch.
Attachment #283809 - Flags: superreview?(roc)
Attachment #283809 - Flags: superreview+
Attachment #283809 - Flags: review?(rbs)
Attachment #283809 - Flags: review+
Attachment #283809 - Flags: approval1.9+
Flags: blocking1.9?
Flags: blocking1.9?
Fixed.  Need to land test once we sort out where...
Status: NEW → RESOLVED
Closed: 13 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
> +                         PR_TRUE, childItems, PR_FALSE);

This should have been:

+                         PR_TRUE, childItems, isBlock);

Regression tests caught it, yay.
Crashtest checked in.
Flags: in-testsuite? → in-testsuite+
Crash Signature: [@ IsPercentageAware]
You need to log in before you can comment on or make changes to this bug.