Last Comment Bug 398624 - PRBool misuse bugs in extensions/pref/
: PRBool misuse bugs in extensions/pref/
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Preferences: Backend (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: mozilla1.9beta1
Assigned To: (dormant account)
:
Mentors:
Depends on:
Blocks: 266048
  Show dependency treegraph
 
Reported: 2007-10-04 15:48 PDT by (dormant account)
Modified: 2007-10-19 16:29 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Prbool correction (2.02 KB, patch)
2007-10-04 15:48 PDT, (dormant account)
mozilla: review+
sayrer: approval1.9+
Details | Diff | Review

Description (dormant account) 2007-10-04 15:48:29 PDT
Created attachment 283628 [details] [diff] [review]
Prbool correction

This was found by prcheck. This is my favourite bug so far. Turned out the function definition didn't match the declaration and some callers called it as it was specified in the definition and some in the declaration.
Comment 1 David :Bienvenu 2007-10-04 15:54:07 PDT
Comment on attachment 283628 [details] [diff] [review]
Prbool correction

Thx for the patch. The other callers (the ones that were wrong) were OK because they passed 0 for both. So if I'm reading this correctly, there's no actual runtime bug, just code that looked wrong...
Comment 2 (dormant account) 2007-10-15 17:23:12 PDT
Checking in extensions/pref/autoconfig/src/nsReadConfig.cpp;
/cvsroot/mozilla/extensions/pref/autoconfig/src/nsReadConfig.cpp,v  <--  nsReadConfig.cpp
new revision: 1.19; previous revision: 1.18
done
Comment 3 Reed Loden [:reed] (use needinfo?) 2007-10-16 17:33:31 PDT
Backed out as part of the fun-lovin' Tp-regression-finding game!
Comment 4 Reed Loden [:reed] (use needinfo?) 2007-10-19 16:29:53 PDT
Relanded.

Checking in extensions/pref/autoconfig/src/nsReadConfig.cpp;
/cvsroot/mozilla/extensions/pref/autoconfig/src/nsReadConfig.cpp,v  <--  nsReadConfig.cpp
new revision: 1.21; previous revision: 1.20
done

Note You need to log in before you can comment on or make changes to this bug.