Crash at startup on systems with Pango 1.18 [@ GlyphBuffer::Flush] [@ _cairo_cache_freeze]

RESOLVED FIXED

Status

()

Core
Graphics
--
blocker
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: Caio Tiago Oliveira (asrail), Assigned: Caio Tiago Oliveira (asrail))

Tracking

({crash, regression})

Trunk
x86
Linux
crash, regression
Points:
---
Bug Flags:
blocking1.9 ?

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(4 attachments, 1 obsolete attachment)

(Assignee)

Description

10 years ago
Created attachment 283876 [details]
Stack trace

It always crashes at startup while using pango 1.18.

It's a regression of bug 362682.
(Assignee)

Comment 1

10 years ago
Created attachment 283878 [details]
Another stack

This one is happening more frequently right now.

Updated

10 years ago
Severity: major → critical

Comment 2

10 years ago
Created attachment 283908 [details]
valgrind log

Comment 3

10 years ago
Created attachment 283909 [details]
what appears to be a dump file that valgrind spit out.

Comment 4

10 years ago
I also have a 90MB core.`pidof firefox-bin` file. It compresses to 3.0MB. Should I attach that as well?
Severity: critical → blocker
Flags: blocking1.9?
(Assignee)

Comment 5

10 years ago
About pango versions and blocking 1.9... in a near future Ubuntu Gutsy and Debian Lenny will be released with pango 1.18, so the amount of people suffering from this will increase a lot. Current users of such non-released versions already use pango 1.18.

Revert to using pango 1.16 or older requires downgrade of essential packages, so a change of version is not an *easy* workaround.

Since this is a regression introduced by a 1.9 blocker, it should got some high priority.


@hussam: I don't think it's needed.

Updated

10 years ago
Summary: Crash at startup [@ GlyphBuffer::Flush] [@ _cairo_cache_freeze] → Crash at startup on systems with Pango 1.18 [@ GlyphBuffer::Flush] [@ _cairo_cache_freeze]
(Assignee)

Comment 6

10 years ago
Created attachment 283940 [details] [diff] [review]
Proposed patch

Maybe that should be ifdef'd to zero, as Stuart suggested...
Assignee: nobody → asrail
Status: NEW → ASSIGNED

Updated

10 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 7

10 years ago
Would have been nice to #if 0 it instead of removing.

Comment 8

10 years ago
ok, I'm pretty sure the crash is caused by a broken internal cairo version.  I just ran the version that was crashing for people using system cairo and it works.  Lets fix properly by updating cairo or something.  I can't reopen.  Please do.
(Assignee)

Comment 9

10 years ago
Comment on attachment 283940 [details] [diff] [review]
Proposed patch

Stuart submitted a patch ifdefing 0 yesterday.
Attachment #283940 - Attachment is obsolete: true
(Assignee)

Comment 10

10 years ago
(In reply to comment #8)
> ok, I'm pretty sure the crash is caused by a broken internal cairo version.  I
> just ran the version that was crashing for people using system cairo and it
> works.  Lets fix properly by updating cairo or something.  I can't reopen. 
> Please do.

It is already known it works with system cairo.

There is not any logic error on the cairo's code inside Mozilla source... I've seen that some snippet of code should work, but sometimes the scaled font got overridden somehow.

There is a mention to the fact that it works with system cairo, but... Mozilla won't compile using system cairo with any released version of cairo.

Since it's a stopper, it's better to ifdef 0 for now.



Just to make it clear, the crash is inside cairo due to cairo memory management issues. It's better not to use that function for now than to enforce people using some specific (probably not yet released) version of cairo.

Comment 11

10 years ago
(In reply to comment #10)
> (In reply to comment #8)
> > ok, I'm pretty sure the crash is caused by a broken internal cairo version.  I
> > just ran the version that was crashing for people using system cairo and it
> > works.  Lets fix properly by updating cairo or something.  I can't reopen. 
> > Please do.
> 
> It is already known it works with system cairo.
> 
> There is not any logic error on the cairo's code inside Mozilla source... I've
> seen that some snippet of code should work, but sometimes the scaled font got
> overridden somehow.
> 
> There is a mention to the fact that it works with system cairo, but... Mozilla
> won't compile using system cairo with any released version of cairo.
> 
> Since it's a stopper, it's better to ifdef 0 for now.
> 
> 
> 
> Just to make it clear, the crash is inside cairo due to cairo memory management
> issues. It's better not to use that function for now than to enforce people
> using some specific (probably not yet released) version of cairo.

The actual issue is using scaled font from system cairo with included cairo.  The correct fix is to make the conditional also check if system cairo is being used.
Crash Signature: [@ GlyphBuffer::Flush] [@ _cairo_cache_freeze]
You need to log in before you can comment on or make changes to this bug.