Firefox does not auto detect windows domain auto-proxy settings configured by IE/windows

RESOLVED DUPLICATE of bug 28998

Status

()

RESOLVED DUPLICATE of bug 28998
11 years ago
11 years ago

People

(Reporter: fajwilson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/200710804 Minefield/3.0a9pre

My work place has a forced web caching proxy. Windows (Internet Explorer) will configure the appropriate proxy settings automatically if you check "Tools>Internet Options>Connnections>LAN Settings>Automatically detect settings". This is *all* you have to do (There is no .PAC file or any need for entering any machine names or ports). I would guess that my organisation maybe running some sort of Microsoft dhcp extension to make this work (but I am not sure). The proxy is 

Regardless of how these settings are retrieved IE works but Firefox does not. 

Once Firefox has been configured to detect proxy settings automatically (via: "Tools>Options>Advanced>Network>(Connection)Settings>Auto-detect proxy settings for this network") one would expect it to consult IE's settings. However Firefox does not seem to do this in this case.

****

I think the mechanism being used to get the proxy settings is the "Web Proxy Autodiscovery Protocol (WPAD)":
http://en.wikipedia.org/wiki/Web_Proxy_Autodiscovery_Protocol
http://www.ehsco.com/reading/20061003iwc1.html (See section on auto-discovery mechanisms)
http://msdn2.microsoft.com/en-us/library/aa384123.aspx (possibly the functions you need to fix this bug!)

Reproducible: Always

Steps to Reproduce:
1. Connect a Windows computer with FF to a network with a forced (but non-intercepting) proxy and Windows Domain controller (probably 2k3, probably handles dhcp).
2. Configure Windows to auto-detect proxy settings (via Internet Explorer "Tools>Internet Options>Connnections>LAN Settings>Automatically detect settings" or "Control Panel>Internet Options>Connections>LAN Settings>Automatically detect settings"
3. Configure Firefox to auto-detect proxy settings (via: "Tools>Options>Advanced>Network>(Connection)Settings>Auto-detect proxy settings for this network")
4. Attempt browse external sites.
Actual Results:  
External sites will not load in Firefox, but will load in Internet Explorer.

Expected Results:  
Firefox will load external sites.
(Reporter)

Comment 1

11 years ago
Note I submitted this with FF2 but have tested this use-case with FF3alpha (latest build). Both are affected by this bug.
(Reporter)

Comment 2

11 years ago
Might be the same as bug #28998 (https://bugzilla.mozilla.org/show_bug.cgi?id=28998). It is marked as resolved, but on skim reading this bug, it seems as though the bug was only resolved in a certain branch of FF.

Sorry if this is dupe, I didn't know of WPAD before I started submitting, otherwise I would have searched for it specifically!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 28998
You need to log in before you can comment on or make changes to this bug.