the outline of the border for -moz-border-radius is not shown in particular circumstances

VERIFIED DUPLICATE of bug 399258

Status

()

Firefox
General
--
minor
VERIFIED DUPLICATE of bug 399258
10 years ago
10 years ago

People

(Reporter: Martin Roberts, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007100505 Minefield/3.0a9pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007100505 Minefield/3.0a9pre

The algorithm/condition to determine whether to draw the curved border is incorrect and is appears to still based on conditions which determine whether to draw a standard rectangular border, which means that at times the border outline is not drawn when in fact it should be.

Reproducible: Always

Steps to Reproduce:
1. The following code fragment will correctly display a blue rectangle with a thick black border.

<div id="test" 
  style="position:absolute;
    background-color:#0000ff;
    border: 10px solid #000000;
    left:-25px; 
    top   :-25px;
    width : 3000px; 
    height:3000px;
    -moz-border-radius    : 160px; 
  "> 
</div>

2. alter the above code so that the width and height are 3000px.
3. Notice that the top-left hand curved corner still appears as expected but the black outline has not been drawn.
Actual Results:  
1. Notice that the top-left hand curved corner still appears as expected but the black outline has not been drawn.

2. Note that if you change the width and height to say 300px, then everything works as it should.



Expected Results:  
Whenever we see a curved blue region then we should also see a black outline. 

The algorithm/condition to determine whether to draw the curved border is incorrect and is appears to still based on conditions which determine whether to draw a standard rectangular border.
(Reporter)

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 399258

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.