Tabbed Browsing options break javascript focus() method

RESOLVED DUPLICATE of bug 357379

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 357379
11 years ago
2 years ago

People

(Reporter: Mekka, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

If a user has certain tabbed browsing options set, firefox incorrectly ignores calls to the window.focus() method.  This means that legitimate pop-ups (such as forms and explanations, etc) that would like to open in a new tab and be focused do not work.  The only work around for designers is to force the pop up to open in an actual new window, which violates the user's preferences to show new windows in a new tab where possible.  This problem seems to affect FF 2.x for mac and PC differently.  

Reproducible: Always

Steps to Reproduce:
1.a In FF 2.0 mac, set firefox > preferences >new pages should be opened in a new tab. Make sure "switch to a newly opened tab is not selected"

1.b in FF 2.0 PC set tools > options > force new windows to be new tabs

2. Consider the html snippet included below.  




--- html snippet -- 

<html>
<head>
<title>blah</title>
</head>
<body>
  <a
    href='ffdemo.html'
    target='target1'
    onclick='newWin = window.open(this.href, this.target, "left=0,width=800"); newWin.focus(); return false;'>
    Works</a>
  <a
    href='ffdemo.html'
    target='mytarget'
    onclick='newWin2 = window.open(this.href, this.target); newWin2.focus(); return false;'>
    Doesn't Work</a>
</body>
Actual Results:  
firefox ignores the window.focus() on the "does not work version", because it opens it in a tab.  firefox performs the window.focus on the "works" version because the extra width and location parameters force it to open in an actual new window, and not a tab.  Therefore the problem appears to be with the tabbed browsing code.

FF PC continues to open multiple windows, despite the target name being the same.

FF Mac opens a single window, but does not transfer focus to it.   

Expected Results:  
clicking on either link should have the effect of opening a new window if none exists, or reloading the content of the new window if it already exists. Multiple windows should not be created, and the new window should gain the focus.

I think this should be classified as 'normal' rather than 'minor' or 'trivial' because pop-ups are a sensitive issue for many users.  The workaround for this bug (forcing a new window) causes a more obtrusive experience for the user, and forces designers to disregard the user's new window preferences.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 357379
This bug has been tagged for regression and or closure.
I cannot produce the error messages in Release 
Version 	45.0.1
Build ID 	20160315153207
User Agent 	Mozilla/5.0 (Windows NT 5.1; rv:45.0) Gecko/20100101 Firefox/45.0
Considering this I will mark this issue as Resolved-WORKSFORME. 
If anyone can still reproduce it, feel free to reopen the issue and provide updated steps/links.
You need to log in before you can comment on or make changes to this bug.