Closed Bug 399471 Opened 14 years ago Closed 14 years ago

find as you type bar appears when triggered but accepts no input

Categories

(Core :: Widget: Cocoa, defect, P2)

x86
macOS
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: gkw, Assigned: smichaud)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007101104 Minefield/3.0a9pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007101104 Minefield/3.0a9pre

The find as you type toolbar could not accept input at that particular web site (at the URL) after doing certain steps.

Reproducible: Always

Steps to Reproduce:
1. Start up Minefield
2. Go to About Minefield
3. Click credits
4. Click contributors link. A new window pops up.
5. Scroll down to the bottom and click the "something like this" link.
6. When URL is loaded, press "/" key.
Actual Results:  
The toolbar shows up but accepts no input.

Expected Results:  
The toolbar shows up and accepts input.

Firefox 2.0.0.7 doesn't exhibit this problem. Trunk-only.
missed a step:

...
5. Scroll down to the bottom and click the "something like this" link.
-> When URL is loaded, on pressing "/" key nothing occurs. A mouse-click anywhere on the webpage refocuses onto the main UI.
6. press "/" key.

Actual Results:  
The toolbar shows up but accepts no input.

(See screenshot. There is no cursor for input.)
Looks like another focus bug, possibly related to bug 354768.
Status: UNCONFIRMED → NEW
Component: Find Toolbar / FastFind → Widget: Cocoa
Ever confirmed: true
Product: Firefox → Core
Version: unspecified → Trunk
Assignee: nobody → smichaud
Flags: blocking1.9?
Assignee: smichaud → joshmoz
QA Contact: fast.find → cocoa
Assignee: joshmoz → smichaud
Flags: blocking1.9? → blocking1.9+
Gary, did this just start happening (i.e., in the 11 Oct build)?  If so, it may well be bug 399740.
> Gary, did this just start happening (i.e., in the 11 Oct build)?

I see this in Minefield 2007-09-26-04-trunk (I haven't yet tested
anything older).

> If so, it may well be bug 399740.

It probably isn't.
By the way, this isn't really an FAYT bug:  You can't type into _any_
of the textfields in the window you get by clicking on the "something
like this" link.

It's really a focus bug.
Target Milestone: --- → mozilla1.9 M10
Priority: -- → P1
Priority: P1 → P2
Target Milestone: mozilla1.9 M10 → ---
I've confirmed that this bug is a focus bug -- it's fixed by my patch
for bug 403232 (attachment 290742 [details] [diff] [review]).

Here's a tryserver build (of Minefield), made using that patch.

https://build.mozilla.org/tryserver-builds/2007-11-29_13:05-smichaud@pobox.com-focus/
Depends on: 403232
Fixed by patch for bug 403232, which just landed on trunk.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
(Following up comment #8)

The first time I landed a patch for bug 403232, I had to back it out
because of Mochitest failures.  I've just landed another version of
the patch, which had no problems.
verified fixed using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008050621 Firefox/3.0pre and the steps to reproduce from gary

--> verified fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.