KB article: Recovering important data from an old profile

VERIFIED FIXED

Status

--
minor
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: jason.barnabe, Assigned: stevee)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Comment 1

11 years ago
Taking... I'll have a crack at this. I presume I won't have to mention any 1.5.0.x related things in this? And also, this article will differ from http://support.mozilla.com/kb/Backing+up+your+information because it mentions what data specific files store, rather than blindly backing up the whole profile?
Status: NEW → ASSIGNED
(Assignee)

Updated

11 years ago
Assignee: nobody → steve.england
Status: ASSIGNED → NEW
(Assignee)

Comment 2

11 years ago
Also, are we happy use Transferring rather than Migrating?
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED

Comment 4

11 years ago
(In reply to comment #1)
> Taking... I'll have a crack at this. I presume I won't have to mention any
> 1.5.0.x related things in this? And also, this article will differ from
> http://support.mozilla.com/kb/Backing+up+your+information because it mentions
> what data specific files store, rather than blindly backing up the whole
> profile?
> 

You don't have to mention 1.5.x stuff as Mozilla doesn't support it anymore.

About the list of files stored in a profile, there are already plans to write a separate article for that. Please read http://groups.google.com/group/mozilla.support.planning/browse_thread/thread/cfcbf66322a7f24c/32de9e8d81e1981e?#32de9e8d81e1981e and see if this overlaps your work here, and whether or not you can work together on it (or somehow reuse the same data).

(In reply to comment #2)
> Also, are we happy use Transferring rather than Migrating?

Being from Sweden, my preference is probably irrelevant. I'm fine with either. :) If you feel Migrating is better, it probably is.

Comment 5

11 years ago
Jason, do you remember what the difference is between this article and <http://support.mozilla.com/kb/Backing+up+your+information>? Did I state the difference somewhere? If I did, I completely forgot, and I don't know what the difference is. :-[
(Reporter)

Comment 6

11 years ago
"Backing up your information" tells you how to do a full backup of a profile. "Transferring data to a new profile" will tell you how to move certain settings from one profile to another (e.g. when the original is corrupted).

Comment 7

11 years ago
In that case, is there a better name for the article? You know I'm a stickler, when it comes to article names. :)

We should at least state the distinction in some way, within the article.

Comment 8

11 years ago
How about "Importing settings from an old profile?"

Comment 9

11 years ago
I'm thinking something more like "Importing specific elements..."
(Assignee)

Comment 10

11 years ago
I'd like some feedback and direction on the article so far.

1) Should I include the 'Locating your profile folders' and 'Copying files between profile folders' instructions, or assume the user knows how to do this?

2) Should I take users to the areas of UI that the files refer to? eg: in the 'Download actions' part, where I take the uesr to the mimetype prefs to show them what settings the mimeTypes.rdf stores.

3) What about the layout?

AIUI, there's going to be an article on covering what _all_ files do; this article is just the major files that the average end user will be most interested in. If this understanding is correct, then are the files listed there OK, or should we also get rid of entries like User styles (most end users will never use these), Anti-phishing list (will get automatically redownloaded)? Should i also include the /microsummary-generator/ directory?

plus any other questions / comments / flak :-)
(In reply to comment #10)
> I'd like some feedback and direction on the article so far.
> 
> 1) Should I include the 'Locating your profile folders' and 'Copying files
> between profile folders' instructions, or assume the user knows how to do this?

I think "Preparation" already tells the user where to locate his/her profile; so there's no need for locating the profile after that.

> 2) Should I take users to the areas of UI that the files refer to? eg: in the
> 'Download actions' part, where I take the uesr to the mimetype prefs to show
> them what settings the mimeTypes.rdf stores.

In that specific case, no. If there's an article that covers it, like <http://support.mozilla.com/kb/Managing+file+types>, point to that. If not, go ahead.

> 3) What about the layout?
> 
> AIUI, there's going to be an article on covering what _all_ files do; this
> article is just the major files that the average end user will be most
> interested in. If this understanding is correct, then are the files listed
> there OK, or should we also get rid of entries like User styles (most end users
> will never use these), Anti-phishing list (will get automatically
> redownloaded)? Should i also include the /microsummary-generator/ directory?

Keep the user* files in it. Remove the anti-phishing. I don't see a microsummary-generator folder in my profile. Is that from an extension?
(Assignee)

Comment 12

11 years ago
(In reply to comment #11)
> 
> I think "Preparation" already tells the user where to locate his/her profile;
> so there's no need for locating the profile after that.

Hmm. Welp, I've left it in at the moment for the simple reason I think that (1) users will skip over the backup part, and (2) even if they do back up their data, they might not make the connection between a profile folder, and the files inside the profile folder. But feel free to remove it.
 
> In that specific case, no. If there's an article that covers it, like
> <http://support.mozilla.com/kb/Managing+file+types>, point to that. If not, go
> ahead.

I've linked to other sumo articles where I can, and explained about the data where articles don't exist. I haven't been able to do this for hostperm.1 because the UI elements that write to this file are all over the shop, and cert8.db because I'm still not exactly what this file contains.

> Keep the user* files in it. Remove the anti-phishing. I don't see a
> microsummary-generator folder in my profile. Is that from an extension?

Done. The \microsummary-generator\ dir is present if the user has manually added a Live Title, or user a microsummary generator to make a Live Title - If their Live Titles are from being embedded in a web-page, then this dir doesn't exist.

Should I perhaps merge the Autocomplete History and Bookmarks History headings into one History section? Also, note to self, rework the opening gambit because I mention 'important data' 4 times.
(Assignee)

Comment 13

11 years ago
Oh, and what about a new main heading for files you shouldn't really copy across? (for extensions/preferences/localstore)
(Assignee)

Comment 14

11 years ago
Or maybe we should loose the extensions/preferences/localstore bit all together; after all, if a user is taking the trouble to make a new profile and migrate their unique data over, then maybe loosing their extensions and preferences would be a good thing to happen, since most problems are extension/pref related.
(Assignee)

Comment 15

11 years ago
ping?
(Reporter)

Comment 16

11 years ago
If you don't think it's a good idea to copy something over, I think you should just leave it out. Maybe also include a warning not to just copy everything.

I don't see the need to combine Autocomplete History and Bookmarks History.
(Assignee)

Comment 17

11 years ago
OK I have removed the text about how to copy over extensions and preferences (prefs.js / user.js / localstore.rdf), and included a warning that this article does not explain how to copy such files across.

questions / comments / flak?
(Reporter)

Comment 18

11 years ago
-I don't think "Locating your profile folders" needs its own section. Just put the instructions in either of the surrounding sections.
-"please read the Profile folder locations article.". That's the Profile folder locations section in the Profiles article.
-"whilst" -> "while"
-"it is perfectly possible you could" -> "it is possible that you could"
-Do Passwords, Managing file types, and Search Bar articles really have any pertinent information?
-Why are you giving instructions on how to see cookies and history?
I think we should cover all the files. Some people migrate from one machine to another, but only want to grab the essentials.  So someone may want to copy over the prefs, or they may want to copy over the extensions. I think it makes sense to explain why you wouldn't want to transfer them over, but mention them still.
Copying from one machine to another is covered in <http://support.mozilla.com/kb/Moving+your+Firefox+bookmarks+and+settings>.
This article is more about recovering essential data. prefs.js includes the home page, so I say include it. But don't cover every file. 
(Assignee)

Comment 21

11 years ago
The unquoted points from comment 18 I will sort out. For these:

(In reply to comment #18)
> -Do Passwords, Managing file types, and Search Bar articles really have any
> pertinent information?
> -Why are you giving instructions on how to see cookies and history?

Simply because people might not know what passwords/filetypes/searchbar/cookies/history are, so I was showing them what they are so they can make an informed decision as to whether they want to copy them over or not.

Should I just get rid of all these references? (I wasn't sure if I was going to like them when I started, and now they're done I'm not sure if I do like them - so removing them would certainly be fine with me).

(In reply to comment #20)
> This article is more about recovering essential data. prefs.js includes the
> home page, so I say include it. But don't cover every file. 

The preferences stored in prefs.js are often the prefs responsible for causing problems users are trying to get away from by making a new profile and copying their files across. I really don't think the prefs.js file should be included in this article.

However, if you insist, then it should come with a large shouty warning. The other thing we could do would be include a new section warning about the fact the user will loose their homepage so they should make a note of their current pages.
(Reporter)

Comment 22

11 years ago
(In reply to comment #21)
> Simply because people might not know what
> passwords/filetypes/searchbar/cookies/history are, so I was showing them what
> they are so they can make an informed decision as to whether they want to copy
> them over or not.
> 
> Should I just get rid of all these references? (I wasn't sure if I was going to
> like them when I started, and now they're done I'm not sure if I do like them -
> so removing them would certainly be fine with me).

You can link to them like you do with bookmarks, but I don't see any reason to explicitly tell them to go look there.
(Assignee)

Comment 23

11 years ago
There wasn't a cookies article available when I first drafted this. There is now, so I can link to that article. But for history there is nothing, so I'll just get rid of the "You can see your history by click on the View menu at the top of the Firefox window, and selecting Sidebar and then History." part right?
(Reporter)

Comment 24

11 years ago
Yeah.
(Assignee)

Comment 25

11 years ago
OK I've removed the bits that were unnecessary.

Now I just need a call made on the prefs.js thing. Do we:
1) Not mention it because it's often the cause of problem people are trying to get away with, and put in something about noting your homepage. (If so, what kind of homepage warning is appropriate)

2) Mention it, but with warnings?

Also I've just noticed that in the 'Copying files between profile folders' section i'm mentioning right clicking to copy and paste, and i guess goddamn macs don't have right mouse buttons.. so what do they have and how do you want me to rework this bit?
If prefs.js is often the cause, mentioning it for the sake of preserving the home page is not worth it. Don't include prefs.js.

With regards to right-click on Mac, don't worry about it for now. We're eventually going to use a tag that will allow us display text specific to OS. When we do, it will be a matter of finding all instances where it is needed, and updating all instances at once.
I don't understand why we're creating this article specifically with some problems in mind.  The article can apply to people who want to migrate their settings for any reason.  We can also explain to people how to move some files over at a time, or warn them that prefs.js and extensions folders are often the causes of problems.  If you're having a problem, move them last to see if the profile works without them.

There are plenty of other settings in prefs.js that people may want to keep.  If prefs.js is the problem then the extensions are probably fine.  There are also cases where the problem is in the chrome folder, and moving all of these settings is fine.

IMO this article should be comprehensive like the MZ article, and it or the basic troubleshooting article should include instructions on how to determine which files exactly need to be replaced. It doesn't make sense to me to support users part way through a solution, and then stop at a point that means they can unnecessarily lose settings and have to install extensions over again.
(Reporter)

Comment 28

11 years ago
I agree with Chris, don't mention prefs.js.
if prefs.js is the problem, shouldn't the user be using the safe mode panel to rest it rather than transferring everything to a new profile?
(Reporter)

Comment 30

11 years ago
This isn't about saving every shred of information possible. This is about making a simple as possible process that will get the majority of users going again while keeping most of their data.

For saving every shred of information possible in 60 easy steps, there's http://support.mozilla.com/kb/Basic+Troubleshooting
(Assignee)

Comment 31

11 years ago
OK I've (hopefully) taken notice of all the comments made so far and reworked the article appropriately. Sorry it's taken so long, i've been a little busy the last week or two. Any further comments?
(Reporter)

Comment 32

11 years ago
Content-wise, this looks very good. Only comments left are about wording and formatting.

(In reply to comment #18)
> -"whilst" -> "while"
> -"it is perfectly possible you could" -> "it is possible that you could"

-"This article will describe how to find your Firefox profile folder, the names of the files that store your important data, and how to copy the files from an old profile folder to a new one." You're not describing how to find the profile folder.
-"Before starting it is advisable to make a complete backup of your existing Firefox profile. Please read the Backing up your information article for how to do this." A little wishy-washy. Say something like "[Back up your profile] before making any changes in case blah blah blah".
-"To create a brand new Firefox profile, please read the Profiles article" Reading the article won't give the user a new profile :). "For information on creating..."
-How about putting "Create a new Firefox profile" under "Preparation"?
-"Note: Firefox must be closed down whilst copying files between profile folders." put this at the top of the section
-"Identify your most important data" and "Your important data and their files" can be merged into one section.
-Backslashes in file paths are a Windowsism. Both Mac and Linux use forward slashes. Though Windows does have more users...
(In reply to comment #30)
> This isn't about saving every shred of information possible. This is about
> making a simple as possible process that will get the majority of users going
> again while keeping most of their data.
> 

I know it's not, it's about transferring some of your settings but not all.  I think we're crippling the article for most of the use cases by not mentioning something like prefs.js which contains all of the changes you make through the options panel and about:config.  Someone may wish to create a new profile and only take their passwords bookmarks and settings. Someone may wish to create a new profile with their extensions and passwords and nothing else.

In the case we're talking about, where someone is creating a new profile and migrating settings because something is broken, it's the wrong approach to assume prefs.js is the problem.  If they've been troubleshooting correctly they'll have already ruled it out.  If they haven't already ruled it out we should provide the steps to do so and not just ignore a file that contains important settings.  But even moreso for the extensions folder.  That's potentially a lot of work for someone who doesn't realize they can transfer their 20+ extensions to another profile.
(Reporter)

Comment 34

11 years ago
We're not assuming anything in particular is the problem. We're listing files that are useful and are very unlikely to be causing the problem. The probability of prefs.js or extensions causing the problem is higher than "very unlikely".
My turn. :)
- I don't see a need to the "This article will describe how to..." paragraph. The intro is good enough without it.

- rename "preparation" to "back up your current profile"

- we are splitting the profiles article, so the 'create a profile' link will need to be updated. I'll do those reviews today, to make sure those articles are live.

- is "identifying your most important data" needed?

- are both password files required?

- let's weigh the importance of each piece of data: I don't think cookies or history are more important than things like host permissions or search engines. List them by order of importance and commonality. (e.g. userChrome.css is important, but not commonly used enough.)

- put the links to other articles at the end of the descriptions.
-- heading
-- file(s)
-- description. End it with "For more information see ((articlename))."
(Assignee)

Comment 36

11 years ago
(In reply to comment #32)
> -"This article will describe how to find your Firefox profile folder, the names
> of the files that store your important data, and how to copy the files from an
> old profile folder to a new one." You're not describing how to find the profile
> folder.

This sentence was removed as per chris' comment in comment 35.

> -"Before starting it is advisable to make a complete backup of your existing
> Firefox profile. Please read the Backing up your information article for how to
> do this." A little wishy-washy. Say something like "[Back up your profile]
> before making any changes in case blah blah blah".

I've reworded this, tho I dodn't really understand what was wishy-washy before, so just let us know if it's ok now :-)

> -"To create a brand new Firefox profile, please read the Profiles article"
> Reading the article won't give the user a new profile :). "For information on
> creating..."

Done.

> -How about putting "Create a new Firefox profile" under "Preparation"?

Preparation has been renamed, so I don't think this would make sense anymore.

> -"Note: Firefox must be closed down whilst copying files between profile
> folders." put this at the top of the section

Done.

> -"Identify your most important data" and "Your important data and their files"
> can be merged into one section.

I merged the 'Identify your most important data' section with the end of the 'Copying files between profile folders' section. 

> -Backslashes in file paths are a Windowsism. Both Mac and Linux use forward
> slashes. Though Windows does have more users...

Yes :-)



(In reply to comment #35)
> - I don't see a need to the "This article will describe how to..." paragraph.
> The intro is good enough without it.

Removed.

> - rename "preparation" to "back up your current profile"

Done.

> - we are splitting the profiles article, so the 'create a profile' link will
> need to be updated. I'll do those reviews today, to make sure those articles
> are live.

Links changed.

> - is "identifying your most important data" needed?

Merged into end of previous section

> - are both password files required?

Yes.

> - let's weigh the importance of each piece of data: I don't think cookies or
> history are more important than things like host permissions or search engines.
> List them by order of importance and commonality. (e.g. userChrome.css is
> important, but not commonly used enough.)

The article was originally written with the list of files in order of what I thought was their importance. Evidently you have a different idea as to what the most important files are, as will everyone else I guess :-) I've re-ordered them again, but really, someone come up with what order the files should be in and I'll order them that way.

The files are (in alphabetical order): Autocomplete History, Bookmarks, Browsing History, Cookies, Download Actions, Passwords, Personal Dictionary, Search Engine, Security Certs, Site-specific Prefs, UserContent/UserChrome. Let the fight begin :-)

> - put the links to other articles at the end of the descriptions.
> -- heading
> -- file(s)
> -- description. End it with "For more information see ((articlename))."

Done.
(Reporter)

Comment 37

11 years ago
Good work! Moved to KB.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Status: RESOLVED → VERIFIED

Updated

11 years ago
Summary: KB article: Transferring data to a new profile → KB article: Recovering important data from an old profile
You need to log in before you can comment on or make changes to this bug.