.shtml, .xhtml should be "HTML Files" in file pickers

VERIFIED FIXED

Status

SeaMonkey
UI Design
P3
trivial
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Sean Richardson, Assigned: Stuart Parmenter)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Overview:
.shtml and .xhtml files are listed by the file pickers in "All Files" mode
but not in "HTML Files" mode.

Steps to reproduce:
1. Place two files in a directory on your local machine; change the 
   extension on one to .shtml, on the other to .xhtml.
2. Choose "Open File" from the File menu.
3. Navigate to that directory.
4. Verify that the files appear in the "All Files" listing.
5. Change the picker to "HTML Files" mode.

Actual Results:
Neither .shtml not .xhtml files appear in the listing.

Expected Results:
All .shtml and .xhtml files will appear in the listing with .htm and .html 
files.

Does not work correctly with:
2000-05-18-08-M16 nightly binary on WinNT
2000-05-17-08-M16 nightly binary on Linux

This is sorta-4xp: NN 4.7 recognizes .shtml but not xhtml as "HTML Files".

It would be more future-proof to actually match on ..html where the second
"." is a single-character-replacement, but I won't hold my breath...

Nominating for nsbeta3, as that's when the DUPs would likely start rolling in.
(Reporter)

Updated

18 years ago
Keywords: 4xp, nsbeta3
(Reporter)

Comment 1

18 years ago
This turns out to be a one-line change to (line 5 of)
/xpfe/components/filepicker/res/locale/en-US/filepicker.properties
  from
htmlFilter=*.html; *.htm
  to
htmlFilter=*.html; *.htm; *.shtml; *.xhtml

The only question is whether there is any interaction with bug 39902,
"cannot localize nsIFilePicker's filter" -- will the localizations pick up
the filters themselves from the en-US filepicker.properties, or will there
be n sets of filter definitions in n filepicker.properties files for n
localizations, which could potentially get out of sync?
Assignee: don → pavlov
Severity: normal → trivial
(Assignee)

Comment 2

18 years ago
all that is needed was to add that.  39902 has to do with the windows filepicker
code and isn't related to this.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
verif fixed on linux and winnt using opt comm bits 2000.06.02.08. don't think
this is applicable to mac, due to bug 9621. but do lemme know if i'm missing
something there...
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.