Closed Bug 399692 Opened 12 years ago Closed 12 years ago

Crash [@ nsRect::nsRect] [@ nsTreeBodyFrame::CalcHorzWidth] with <xul:treechildren style="display: inline;">

Categories

(Core :: XUL, defect, critical)

x86
macOS
defect
Not set
critical

Tracking

()

VERIFIED FIXED

People

(Reporter: jruderman, Assigned: neil)

References

(Blocks 2 open bugs)

Details

(Keywords: crash, regression, testcase)

Crash Data

Attachments

(2 files)

Loading the testcase crashes Firefox (Mac trunk debug).

Thread 0 Crashed:
0   nsRect::nsRect
1   nsIFrame::GetRect
2   nsTreeBodyFrame::CalcHorzWidth
3   nsTreeBodyFrame::SetBounds
4   nsLeafBoxFrame::Reflow
5   nsLineLayout::ReflowFrame
...

I think this is a regression from within the last few days.  Could it be due to the patch in bug 399376, which changed nsTreeBodyFrame::CalcHorzWidth?
Flags: blocking1.9?
The original code failed when there was a scrollable view but it had no width.
Bug 399376 then changed the failure mode to a lack of a scrollable frame...
Assignee: Jan.Varga → neil
Status: NEW → ASSIGNED
Attachment #284745 - Flags: superreview?(roc)
Attachment #284745 - Flags: review?(roc)
Attachment #284745 - Flags: superreview?(roc)
Attachment #284745 - Flags: superreview+
Attachment #284745 - Flags: review?(roc)
Attachment #284745 - Flags: review+
Attachment #284745 - Flags: approval1.9+
Fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Flags: blocking1.9? → blocking1.9+
Crashtest checked in.
Flags: in-testsuite+
verified fixed using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3pre) Gecko/2007123104 Minefield/3.0b3pre

no crash on testcase - changing to verified fixed
Status: RESOLVED → VERIFIED
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: xptoolkit.trees → xptoolkit.widgets
Crash Signature: [@ nsRect::nsRect] [@ nsTreeBodyFrame::CalcHorzWidth]
You need to log in before you can comment on or make changes to this bug.