bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Password manager no longer filling in password

RESOLVED WORKSFORME

Status

()

Toolkit
Password Manager
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Julia, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

Ever since the last Firefox update, my password manager doesn't fill in my passwords. This is happening on all websites where I have saved passwords. It doesn't prompt for my master password, either.

In the password manager, all of my sites and saved passwords are still present, and it will still prompt me to save new passwords. It seems there's a bug in the loading of a page.

Reproducible: Always

Steps to Reproduce:
1. Save password at a website with consistent url (i.e. www.myspace.com)
2. Close firefox, then re-open
3. Navigate back to site with saved password
4. If necessary, enter username
5. Password will fail to fill in automatically
6. Check Password Manager - the password is saved there correctly
Actual Results:  
Password doesn't fill in automatically

Expected Results:  
Password fills in automatically. If this is the first time I've accessed a saved password since opening Firefox, should also prompt for master password.
Works for me with Firefox 2.0.0.7 on Windows XP. Please retest with a new profile.
If it doesn't happen with a new profile there's some corruption in your password files. In that case make a screenshot of your passwords and then delete or rename the two files signons2.txt en key3.db in your profile.
http://kb.mozillazine.org/Signons.txt
Marking WFM based on comment #1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.